cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce Jones (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-4835) HTTP Conduit configuation not getting picked up under CXF 2.7.3
Date Mon, 18 Feb 2013 23:27:12 GMT
Bruce Jones created CXF-4835:
--------------------------------

             Summary: HTTP Conduit configuation not getting picked up under CXF 2.7.3
                 Key: CXF-4835
                 URL: https://issues.apache.org/jira/browse/CXF-4835
             Project: CXF
          Issue Type: Bug
          Components: Configuration
    Affects Versions: 2.7.3, 2.6.6
         Environment: Windows XP SP3
Java 7u11
            Reporter: Bruce Jones


When upgrading from CXF 2.1.5 to CXF 2.7.3 it appears the HTTP conduits defined in cxf.xml
are no longer used. The code is quite simple and I am guessing is something to do with a change
in the usage of the "name" attribute in the conduit element. I went through all the migration
guides and found no mention of this change. The cxf.xml is below:

{code:title=cxf.xml}
<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xmlns:http-conf="http://cxf.apache.org/transports/http/configuration"
       xsi:schemaLocation="http://cxf.apache.org/transports/http/configuration
           http://cxf.apache.org/schemas/configuration/http-conf.xsd
           http://www.springframework.org/schema/beans
           http://www.springframework.org/schema/beans/spring-beans.xsd">

	<http-conf:conduit name="https://qa4.paymentexpress.com/WS/PXWS.asmx">
        <http-conf:client AllowChunking="false" ProxyServer="localhost" ProxyServerPort="8888"
/>
    </http-conf:conduit>
    <http-conf:conduit name="https://sec.paymentexpress.com/WS/PXWS.asmx">
        <http-conf:client AllowChunking="false" ProxyServer="localhost" ProxyServerPort="8888"
/>
    </http-conf:conduit>
</beans>
{code}

This is a publiclly accessable WSDL file available at:
https://qa4.paymentexpress.com/WS/PXWS.asmx?wsdl

Note: the WSDL appears to have 2 ports defined for the same service. Not sure if the conduit
configuration is getting confused with this?

If I change the name to *.http-conduit it works but this is obviously not an acceptable solution.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message