cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glen Mazza (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-4687) cxf-codegen-plugin breaks mvn deploy when proxy exists
Date Mon, 10 Dec 2012 21:33:26 GMT

    [ https://issues.apache.org/jira/browse/CXF-4687?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13528318#comment-13528318
] 

Glen Mazza commented on CXF-4687:
---------------------------------

It may be good to provide a simple, minimal pom.xml and a settings.xml snippet that illustrates
the problem.  Please don't post anything sensitive (i.e., make everything fictional.)

                
> cxf-codegen-plugin breaks mvn deploy when proxy exists
> ------------------------------------------------------
>
>                 Key: CXF-4687
>                 URL: https://issues.apache.org/jira/browse/CXF-4687
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.7.0
>         Environment: Windows XP; Maven 3.0.3
>            Reporter: Barry Hathaway
>            Priority: Minor
>
> After using the cxf-codegen-plugin, the maven-deploy-plugin fails to execute the deploy
goal with the message: "Failed to deploy artifacts: Could not find artifact....". This only
happens when the maven settings file contains a proxy. If I remove the proxy everything is
fine. Note, the proxy entry also contains a list of nonProxyHosts.  I suspect this may be
the cause since AbstractCodegenMoho does a configureProxyServerSettings without setting the
nonProxyHosts.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message