cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "huanqiuwang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CXF-4387) when I run a "webapp" of CXF in weblogic9.2, it has some errors.
Date Tue, 19 Jun 2012 07:14:42 GMT
huanqiuwang created CXF-4387:
--------------------------------

             Summary: when I run a "webapp" of CXF in weblogic9.2, it has some errors.
                 Key: CXF-4387
                 URL: https://issues.apache.org/jira/browse/CXF-4387
             Project: CXF
          Issue Type: Bug
          Components: JAX-WS Runtime
    Affects Versions: 2.2.12
         Environment: windows xp , weblogic9.2
            Reporter: huanqiuwang


I have found the reason of the problem and I hope you can correct it.
It's my Code;

        JaxWsDynamicClientFactory dcf = JaxWsDynamicClientFactory.newInstance();
        Client client = factory.createClient("wsdl");

[error]:IOException during exec() of compiler "javac". Check your path environment       variable
javax.xml.bind.JAXBException: "" doesnt contain ObjectFactory.class or index 

The errors are result from code that is " p = Runtime.getRuntime().exec(cmdArray)" in the
class of "compiler.class" whose method is "internalCompile ";
 
The real reason is the commond ---"cmdArray" is so long.

when the commond is in Windows xp ,the length of bat commond is limited.
so when it executes the commond ,the commond is not integrated.

I hope you can issue the "-classpath" in "cmdArray" ,it's too long.

Other Environment work well.

In weblogic the classpath of weblogic is big ,it results in "cmdArray" that is long.

I am sorry that my English is not well.

Thank you 



--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message