cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-4263) when I run a "webapp" of CXF in weblogic9.2, it has some errors.
Date Wed, 25 Apr 2012 05:10:26 GMT

    [ https://issues.apache.org/jira/browse/CXF-4263?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13261301#comment-13261301
] 

Freeman Fang commented on CXF-4263:
-----------------------------------

Hi,

You really should post this kind of question on CXF mailing list first but not create a jira
issue directly.

Back to your problem, this looks like your env JAVA_HOME of weblogic point to a jre but not
a jdk, so that can't find javac during runtime, as you use DynamicClientFactory, it need compile
java src code so need javac during runtime.


Freeman
                
> when I run a "webapp" of CXF in weblogic9.2, it has some errors.
> ----------------------------------------------------------------
>
>                 Key: CXF-4263
>                 URL: https://issues.apache.org/jira/browse/CXF-4263
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.4.7
>         Environment: windows xp or win7,weblogic9.2,sun jdk1.50_04 or jrockit1.50_04
>            Reporter: huanqiuwang
>
> [ERROR] IOException during exec() of compiler "E:\bea\JDK150~1\jre\..\bin\javac.
> exe". Check your path environment variable.
> 2012-4-24 9:10:09 org.apache.cxf.endpoint.dynamic.DynamicClientFactory createCli
> ent
> 严重: Could not compile java files for http://localhost:7001/webroot/webservices
> /HelloWorld?wsdl
> when Running code "Runtime.getRuntime().exec(cmdArray)" errors. only in weblogic it is
wrong!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message