cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Pangburn (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-4262) oauth sample in 2.5.3 release does not build without POM changes
Date Wed, 25 Apr 2012 01:02:06 GMT

    [ https://issues.apache.org/jira/browse/CXF-4262?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13261193#comment-13261193
] 

Jesse Pangburn commented on CXF-4262:
-------------------------------------

That is a better example in many ways, the only thing I don't like is that both client and
server endpoints reside on the same port.  The sample that comes with CXF has them on different
ports so it's easy to see what stuff belongs to the client service and what belongs to the
server service.

That said, are the examples in the CXF source code not maintained anymore?  Seems like they
should at least compile and run, even if they're not the most advanced samples around.

thanks,
Jesse
                
> oauth sample in 2.5.3 release does not build without POM changes
> ----------------------------------------------------------------
>
>                 Key: CXF-4262
>                 URL: https://issues.apache.org/jira/browse/CXF-4262
>             Project: CXF
>          Issue Type: Bug
>          Components: Samples
>    Affects Versions: 2.5.3
>            Reporter: Jesse Pangburn
>            Assignee: Sergey Beryozkin
>            Priority: Minor
>              Labels: oauth, samples
>             Fix For: 2.5.4
>
>
> Tried building oauth client and server samples in 2.5.3 release using provided instruction:
> mvn jetty:run
> Also tried:
> mvn clean install
> These attempts in both client and server fail with the following relevant exception from
the stack trace:
> *****
> Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.apache.cxf.samples:cxf-samples'
not found in repository: Unable to download the artifact from any repository
>   org.apache.cxf.samples:cxf-samples:pom:2.5.3-SNAPSHOT
> *****
> Looking in the pom.xml file for this 2.5.3-SNAPSHOT problem, I find this entry:
> <version>2.5.3-SNAPSHOT</version>
> Changing it to the following resolves the problem and lets the samples build:
> <version>2.5.3</version>
> The client now starts with "mvn jetty:run", but the server still fails with an apparently
unrelated error.  Still, at least it builds with this change.
> The server error is:
> java.lang.NoSuchMethodError: org.objectweb.asm.ClassWriter.<init>(Z)V
> This is apparently due to the use of cglib in the pom.xml.  It can be resolved and let
the server start by changing this entry in the pom.xml:
>         <dependency>
>             <groupId>cglib</groupId>
>             <artifactId>cglib</artifactId>
>             <version>2.1</version>
>         </dependency>
> to this:
>         <dependency>
>             <groupId>cglib</groupId>
>             <artifactId>cglib-nodep</artifactId>
>             <version>2.1</version>
>         </dependency>
> After this it is possible to start "mvn jetty:run" with no errors, though I don't know
enough about the sample to verify its functionality yet.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message