cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CXF-4106) Attachments get lost when WSDL claims HTTP transport but config uses JMS
Date Wed, 21 Mar 2012 21:53:39 GMT

     [ https://issues.apache.org/jira/browse/CXF-4106?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Kulp resolved CXF-4106.
------------------------------

       Resolution: Fixed
    Fix Version/s: 2.5.3
         Assignee: Daniel Kulp
    
> Attachments get lost when WSDL claims HTTP transport but config uses JMS
> ------------------------------------------------------------------------
>
>                 Key: CXF-4106
>                 URL: https://issues.apache.org/jira/browse/CXF-4106
>             Project: CXF
>          Issue Type: Bug
>          Components: Soap Binding
>    Affects Versions: 2.5.2
>            Reporter: Jens Granseuer
>            Assignee: Daniel Kulp
>             Fix For: 2.5.3
>
>         Attachments: swa-client.zip
>
>
> I'm trying to call a service that claims SOAP with Attachments via an HTTP transport.
In reality, however, the service is connected via JMS, so I'm overwriting the transportId
in the Spring config. In the request that is sent out from the client the attachment is missing.
Instead, it is included as a second XML element in the SOAP body.
> According to Dan, this is because the change in transport resets a couple of things to
defaults, see http://cxf.547215.n5.nabble.com/SOAP-w-Attachments-still-supported-td5454220.htm

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message