cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CXF-3954) Could not obtain STS metadata. MEX call failed
Date Mon, 05 Dec 2011 20:36:40 GMT

    [ https://issues.apache.org/jira/browse/CXF-3954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13163026#comment-13163026
] 

Daniel Kulp commented on CXF-3954:
----------------------------------


This SOUNDS like it's not ending up using CXF on the client side but is using the Metro clients
built into Glassfish.  The Metro clients will send a series of MEX calls to the STS until
one succeeds.   It starts of with a couple of SOAP 1.2 calls, then tries some 1.1 calls. That
can end up with a bunch of stack traces on the server side.   One way to minimize this would
be to enable SOAP 1.2 on the STS server.   The first sets of calls should then work.

The error of:

com.sun.xml.ws.api.security.trust.WSTrustException: WST0017:Could not obtain STS metadata.
MEX call to STS http://my.server.org:8081/SecurityTokenService/UT/mex failed.

more or less confirms that.   com.sun.xml.ws.. class would be the metro based client.

                
> Could not obtain STS metadata. MEX call failed
> ----------------------------------------------
>
>                 Key: CXF-3954
>                 URL: https://issues.apache.org/jira/browse/CXF-3954
>             Project: CXF
>          Issue Type: Bug
>          Components: Services
>    Affects Versions: 2.5
>         Environment: Apache Maven 3.0.3 (r1075438; 2011-02-28 18:31:09+0100)
> Maven home: /opt/maven
> Java version: 1.6.0_25, vendor: Sun Microsystems Inc.
> Java home: /usr/java/jdk1.6.0_25/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "2.6.32-71.el6.x86_64", arch: "amd64", family: "unix"
>            Reporter: Jan Bernhardt
>              Labels: mex, securitytokenservice, sts, sts-client
>
> I tried to deploy a cxf consumer as part of a servlet webapplication. When I run my example
using mvn jetty:run everything works just fine as expected. But when I deploy my application
to my glassfish 3 container I get the following error message:
> com.sun.xml.ws.api.security.trust.WSTrustException: WST0017:Could not obtain STS metadata.
MEX call to STS http://my.server.org:8081/SecurityTokenService/UT/mex failed.
> Looking into the STS Server Log it contains the following errors:
> [#|2011-12-05T17:28:46.222+0100|WARNING|glassfish3.1.1|org.apache.cxf.phase.PhaseInterceptorChain|_ThreadID=20;_ThreadName=Thread-2;|Interceptor
for {http://docs.oasis-open.org/ws-sx/ws-trust/200512/}SecurityTokenService has thrown exception,
unwinding now
> org.apache.cxf.binding.soap.SoapFault: A SOAP 1.2 message is not valid when sent to a
SOAP 1.1 only endpoint.
>         at org.apache.cxf.binding.soap.interceptor.ReadHeadersInterceptor.handleMessage(ReadHeadersInterceptor.java:144)
>         at org.apache.cxf.binding.soap.interceptor.ReadHeadersInterceptor.handleMessage(ReadHeadersInterceptor.java:60)
>         at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:263)
>         at org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:123)
> [#|2011-12-05T17:28:46.235+0100|WARNING|glassfish3.1.1|org.apache.cxf.phase.PhaseInterceptorChain|_ThreadID=19;_ThreadName=Thread-2;|Interceptor
for {http://docs.oasis-open.org/ws-sx/ws-trust/200512/}SecurityTokenService has thrown exception,
unwinding now
> org.apache.cxf.interceptor.Fault: No binding operation info while invoking unknown method
with params unknown.
>         at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:60)
>         at org.apache.cxf.interceptor.ServiceInvokerInterceptor$1.run(ServiceInvokerInterceptor.java:58)
>         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
>         at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:138)
>         at org.apache.cxf.workqueue.SynchronousExecutor.execute(SynchronousExecutor.java:37)
>         at org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage(ServiceInvokerInterceptor.java:106)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message