cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CXF-3823) cxf-rt-transport-http-jetty should have the dependency of servlet API 2.5 instead of 3.0
Date Mon, 26 Sep 2011 03:34:26 GMT

     [ https://issues.apache.org/jira/browse/CXF-3823?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Willem Jiang resolved CXF-3823.
-------------------------------

    Resolution: Fixed

Applied the patch into trunk and 2.4.x-fixes branch.

> cxf-rt-transport-http-jetty should have the dependency of servlet API 2.5 instead of
3.0
> ----------------------------------------------------------------------------------------
>
>                 Key: CXF-3823
>                 URL: https://issues.apache.org/jira/browse/CXF-3823
>             Project: CXF
>          Issue Type: Improvement
>          Components: Transports
>    Affects Versions: 2.4, 2.4.1, 2.4.2
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 2.4.3
>
>
> From CXF 2.4.x, we introduced the servlet API 3.0 dependency on the cxf-rt-transport-http-jetty.
> As you know Jetty7 is targeting Servlet API 2.5 and JVM 1.5, if you are try some Servlet3
new feature like continuation, you will get some complain from jetty. Although it could be
peaceful if use doesn't touch the Request or Response object in CXF application when CXF use
the Servlet API 3.0 with cxf-rt-transport-http-jetty, but there are still some user need to
touch the Serlvet API themselves.
> So I want to change the servlet API dependency of cxf-rt-transport-http-jetty to 2.5
to avoid this situation.  

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message