cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Freeman Fang <freeman.f...@gmail.com>
Subject Re: com.springsource.slf4j.jcl_1.5.10 [19] was not resolved.
Date Tue, 09 Aug 2011 12:06:15 GMT
Hi,

OPS4J Pax Logging bundle offer those missing package, so you need  
install OPS4J Pax Logging into your OSGi container first.

Freeman
On 2011-8-9, at 下午5:55, Richard wrote:

> !ENTRY org.eclipse.osgi 2 0 2011-08-09 17:35:29.187
> !MESSAGE The following is a complete list of bundles which are not  
> resolved,
> see the prior log entry for the root cause if it exists:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2011-08-09 17:35:29.187
> !MESSAGE Bundle com.springsource.slf4j.jcl_1.5.10 [19] was not  
> resolved.
> !SUBENTRY 2 com.springsource.slf4j.jcl 2 0 2011-08-09 17:35:29.187
> !MESSAGE Constraints from the fragment conflict with the host:
> Import-Package: org.apache.commons.logging; version="[1.1.1,2.0.0)"
> !SUBENTRY 2 com.springsource.slf4j.jcl 2 0 2011-08-09 17:35:29.187
> !MESSAGE Constraints from the fragment conflict with the host:
> Import-Package: org.slf4j; version="[1.5.10,1.5.10]"
> !SUBENTRY 2 com.springsource.slf4j.jcl 2 0 2011-08-09 17:35:29.187
> !MESSAGE Constraints from the fragment conflict with the host:
> Import-Package: org.slf4j.helpers; version="[1.5.10,1.5.10]"
> !SUBENTRY 2 com.springsource.slf4j.jcl 2 0 2011-08-09 17:35:29.187
> !MESSAGE Constraints from the fragment conflict with the host:
> Import-Package: org.slf4j.spi; version="[1.5.10,1.5.10]"
> ss
>
> Framework is launched.
>
> id	State       Bundle
> 0	ACTIVE      org.eclipse.osgi_3.6.1.R36x_v20100806
> 1	ACTIVE      org.springframework.osgi.extender_1.2.0
> 2	ACTIVE      com.springsource.org.aopalliance_1.0.0
> 3	ACTIVE      org.springframework.osgi.io_1.2.0
> 4	ACTIVE      org.apache.cxf.bundle-minimal_2.2.9
> 5	ACTIVE      org.eclipse.osgi.services_3.2.100.v20100503
> 6	ACTIVE      org.springframework.aop_2.5.6
> 7	ACTIVE      org.springframework.beans_2.5.6
> 8	ACTIVE      org.springframework.osgi.core_1.2.0
> 9	ACTIVE      org.springframework.core_2.5.6
> 10	ACTIVE      org.springframework.context_2.5.6
> 12	ACTIVE      org.apache.geronimo.specs.geronimo- 
> javamail_1.4_spec_1.2.0
> 13	ACTIVE      org.apache.geronimo.specs.geronimo- 
> activation_1.1_spec_1.0.2
> 14	ACTIVE      javax.servlet_2.5.0.v200910301333
> 15	ACTIVE      org.apache.servicemix.bundles.commons-pool_1.5.4.1
> 16	ACTIVE      org.apache.servicemix.bundles.asm_2.2.3.1
> 17	ACTIVE      org.apache.servicemix.bundles.xmlresolver_1.2.0.1
> 18	ACTIVE      org.apache.servicemix.bundles.neethi_2.0.4.1
> 19	INSTALLED   com.springsource.slf4j.jcl_1.5.10
> 20	ACTIVE      com.springsource.slf4j.api_1.5.10
> 21	ACTIVE      org.apache.servicemix.bundles.wsdl4j_1.6.1.1
> 22	ACTIVE      org.apache.servicemix.bundles.xmlschema_1.4.3.1
> 23	ACTIVE      com.springsource.org.apache.commons.logging_1.1.1
>
> --
> View this message in context: http://cxf.547215.n5.nabble.com/com-springsource-slf4j-jcl-1-5-10-19-was-not-resolved-tp4681450p4681450.html
> Sent from the cxf-issues mailing list archive at Nabble.com.

---------------------------------------------
Freeman Fang

FuseSource
Email:ffang@fusesource.com
Web: fusesource.com
Twitter: freemanfang
Blog: http://freemanfang.blogspot.com










Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message