cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CXF-3765) CXF features should use version range for features provided by Karaf
Date Fri, 26 Aug 2011 19:23:29 GMT

    [ https://issues.apache.org/jira/browse/CXF-3765?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13091968#comment-13091968
] 

Jean-Baptiste Onofré commented on CXF-3765:
-------------------------------------------

CXF spring-jms feature doesn't install because spring-jms bundle requires 3.0.6.RELEASE version
(it doesn't use version range).

It means that CXF-3766 should be fix first.

> CXF features should use version range for features provided by Karaf
> --------------------------------------------------------------------
>
>                 Key: CXF-3765
>                 URL: https://issues.apache.org/jira/browse/CXF-3765
>             Project: CXF
>          Issue Type: Improvement
>          Components: OSGi
>    Affects Versions: 2.4.2
>            Reporter: Jean-Baptiste Onofré
>             Fix For: 2.4.3, 2.5
>
>
> Currently, CXF features use specific version for spring and spring-dm features.
> It means that if CXF upgrade to a new Spring version, if Karaf doesn't update to the
same version, CXF won't be installable in Karaf.
> To avoid this situation, CXF should use version range for features provided by Karaf.
> I'm gonna provide a patch for that.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message