cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shyamranny <sh...@proxysystemsindia.com>
Subject Unmarshalling Error: prefix xsd is not bound to a namespace
Date Tue, 19 Jul 2011 04:54:59 GMT
Hi,

I have upgraded my web service and now the new webservice uses CXF. When I
send my old soap message to the new CXF webservice, i am getting the
following response.

'Unmarshalling Error: prefix xsd is not bound to a namespace'.

In my soap request, I have the following element.

'<A700129Naam xsi:type="xsd:string">Shyam</A700129Naam>' Here I use the
prefix 'xsd' and if I add this prefix in the xmlns, this soap will go well.
But our client will not change there soap request. They usually send soap
without specifying the xmlns of 'xsd' and it was working well in the old web
service. They need to send the old soap request.

How can I solve this issue? Can I add namespace and prefix in the spring
configuration file? I have tried a lot like XMLFilterImpl,
AbstractInDatabindingInterceptor, NamespacePrefixMapper etc. But not worked.

Thanks and regards,
Shyam S 

--
View this message in context: http://cxf.547215.n5.nabble.com/Unmarshalling-Error-prefix-xsd-is-not-bound-to-a-namespace-tp4611035p4611035.html
Sent from the cxf-issues mailing list archive at Nabble.com.

Mime
View raw message