cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CXF-3531) CXF doesn't always generate 415 when POSTing to a resource with an invalid media type
Date Wed, 18 May 2011 18:06:49 GMT

     [ https://issues.apache.org/jira/browse/CXF-3531?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sergey Beryozkin resolved CXF-3531.
-----------------------------------

    Resolution: Fixed
      Assignee: Sergey Beryozkin

patch applied, thanks.
Actually, I forgot again to mention the contributor's name in the commit message, really sorry.
The patch point has been accumulated anyway, thanks

> CXF doesn't always generate 415 when POSTing to a resource with an invalid media type
> -------------------------------------------------------------------------------------
>
>                 Key: CXF-3531
>                 URL: https://issues.apache.org/jira/browse/CXF-3531
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 2.4, 2.3.4
>         Environment: JDK 1.6
>            Reporter: Ka-Lok Fung
>            Assignee: Sergey Beryozkin
>            Priority: Minor
>             Fix For: 2.4.1, 2.3.5
>
>         Attachments: cxf.post.mediatype.trunk.diff
>
>
> When you POST to a resource using an invalid Content-Type of "foo", CXF doesn't return
415.
> Instead, CXF throws a 500 because an IllegalArgumentException is thrown instead of a
WebApplicationException.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message