cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cogitate <monish.u...@gmail.com>
Subject Re: CXF-2.4.0 possible bug in HTTP and Local Transport Configs incompatible
Date Tue, 10 May 2011 03:47:29 GMT
thanks Willem however the problem is still unsolved in cxf-2.4.0 

it seems i can't have both local protocol and http protocol within the same
spring context file. 

as the example above shows if i have the following configured and i try to
call an endpoint configured with local protocol

 <import resource="classpath:META-INF/cxf/cxf.xml" />
    <bean class="org.apache.cxf.transport.http.HTTPTransportFactory"
lazy-init="true">
        <property name="transportIds">
            <list>
                <value>http://cxf.apache.org/bindings/xformat</value>
                <value>http://schemas.xmlsoap.org/soap/http</value>
                <value>http://schemas.xmlsoap.org/wsdl/soap/http</value>
            </list>
        </property>
    </bean>

    <bean class="org.apache.cxf.transport.local.LocalTransportFactory"
lazy-init="true">
        <property name="transportIds">
            <list>
                <value>http://cxf.apache.org/transports/local</value>
            </list>
        </property>
    </bean>

HttpTransportFactory needs to be configured since i need the xformat binding
for sending xml requests.
thanks,




--
View this message in context: http://cxf.547215.n5.nabble.com/CXF-2-4-0-possible-bug-in-HTTP-and-Local-Transport-Configs-incompatible-tp4380345p4383631.html
Sent from the cxf-issues mailing list archive at Nabble.com.

Mime
View raw message