cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CXF-2564) CXF uses an old RS API 1.0 - Consider upgrading to 1.1 on branches as well
Date Tue, 04 Jan 2011 18:57:45 GMT

     [ https://issues.apache.org/jira/browse/CXF-2564?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Kulp resolved CXF-2564.
------------------------------

       Resolution: Fixed
    Fix Version/s: 2.3.0


2.3.x implements the 1.1 spec

> CXF uses an old RS API 1.0 - Consider upgrading to 1.1 on branches as well
> --------------------------------------------------------------------------
>
>                 Key: CXF-2564
>                 URL: https://issues.apache.org/jira/browse/CXF-2564
>             Project: CXF
>          Issue Type: Improvement
>    Affects Versions: 2.2.5
>            Reporter: Claus Ibsen
>             Fix For: 2.3.0
>
>
> Looks like trunk is on API 1.1 which is good
> But 2.2.5 is using old 1.0 API
> http://svn.apache.org/repos/asf/cxf/tags/cxf-2.2.5/rt/frontend/jaxrs/pom.xml
> Which does not work well with the rest of the world where 1.1 API is commonly used.
> Consider if possible to upgrade to 1.1 on these branches, or at least on 2.2.x branch

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message