cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <>
Subject [jira] Commented: (CXF-3160) Reduce Code duplication between http transport variants
Date Thu, 02 Dec 2010 10:22:12 GMT


Sergey Beryozkin commented on CXF-3160:

Hi Christian

there's definitely a lot of duplication between rt/transports/http and rt/transports/http_osgi.

rt/transports/http_osgi needs to be refactored, I was actually trying to get rid of some duplications
during the last couple of days, for the changes to make into 2.3.1, but I ended up seeing
the demos I was working upon failing as a result so we'd need a bit more time :-)

I'd probably consider even removing it  altogether and may be adding an OSGI Activator to
the http transport code, not sure yet how plausible it is...The biggest issue with the http_osgi
is that it basically forces all the bundles to share the same context, ex, /cxf by default
or say /services

cheers, Sergey

> Reduce Code duplication between http transport variants
> -------------------------------------------------------
>                 Key: CXF-3160
>                 URL:
>             Project: CXF
>          Issue Type: Improvement
>          Components: Transports
>    Affects Versions: 2.3.0
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>         Attachments: CXF-3160-1.patch
> We still have to much duplicated or very similar code in the http transports. 
> Moving header code from AbstractHttpDestination to Headers
> Moving invokeDestination from ServletController to AbstractServletController to share
this code with http-osgi
> Moving invoke from ServletDestination to AbstractHttpDestination  to share this code
with http-osgi
> Removing doMessage from OsgiDestination
> Removing invokeDestination from OsgiServletcontroller
> Ignoring some mock based tests that do not work anymore. Will have to do some work on
> There are some small changes in the behaviour for http-osgi as we are now using the servlet
code here. It would be great if Sergey or Dan could review this. IdonĀ“t think the differences
are important but I am not sure.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message