cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Beryozkin (JIRA)" <>
Subject [jira] Commented: (CXF-3160) Reduce Code duplication between http transport variants
Date Fri, 03 Dec 2010 10:57:12 GMT


Sergey Beryozkin commented on CXF-3160:

Hi Christian

I've tried to push the updateDests method to a super class so that it can be shared between
the two servlet controllers, and I nearly got there but it was late before 2.3.1 and I also
thought that may be we should step back a bit and see if we can have just a single http transport
but with an osgi activator acting more dynamically....

But what actually broke my demos was the minor update I did to make sure updateDests() was
non-conditional on all the paths, same way as in ServletController. Not sure why, possibly
because two updateDests differ a lot now between the two controllers

cheers, Sergey

> Reduce Code duplication between http transport variants
> -------------------------------------------------------
>                 Key: CXF-3160
>                 URL:
>             Project: CXF
>          Issue Type: Improvement
>          Components: Transports
>    Affects Versions: 2.3.0
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>         Attachments: CXF-3160-1.patch
> We still have to much duplicated or very similar code in the http transports. 
> Moving header code from AbstractHttpDestination to Headers
> Moving invokeDestination from ServletController to AbstractServletController to share
this code with http-osgi
> Moving invoke from ServletDestination to AbstractHttpDestination  to share this code
with http-osgi
> Removing doMessage from OsgiDestination
> Removing invokeDestination from OsgiServletcontroller
> Ignoring some mock based tests that do not work anymore. Will have to do some work on
> There are some small changes in the behaviour for http-osgi as we are now using the servlet
code here. It would be great if Sergey or Dan could review this. IdonĀ“t think the differences
are important but I am not sure.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message