cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-3119) Jetty http integration does not work anymore
Date Mon, 15 Nov 2010 00:58:13 GMT

    [ https://issues.apache.org/jira/browse/CXF-3119?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12931947#action_12931947
] 

Willem Jiang commented on CXF-3119:
-----------------------------------

I just added a comment into the mail thread, 
Please don't put the servlet transport configuration and http jetty configuration together,
they are not supposed to be together :)

> Jetty http integration does not work anymore
> --------------------------------------------
>
>                 Key: CXF-3119
>                 URL: https://issues.apache.org/jira/browse/CXF-3119
>             Project: CXF
>          Issue Type: Bug
>          Components: Transports
>    Affects Versions: 2.3.0
>         Environment: Spring 2.5.6
>            Reporter: Stephane Nicoll
>            Assignee: Willem Jiang
>
> A discussion on this topic can be found here:  http://cxf.547215.n5.nabble.com/cxf-2-3-and-Jetty-7-td3228126.html#a3228126
> I still don't understand the real cause of my problem but at least I can see what change
caused it.
> In 2.21 the JettyHTTPTransportFactory bean stored in cxf-extension-http-jetty.xml is
as follows
> {code:xml}
> <bean class="org.apache.cxf.transport.http_jetty.JettyHTTPTransportFactory"
> 	  id="org.apache.cxf.transport.http_jetty.JettyHTTPTransportFactory"
>     	lazy-init="false" 
>     	depends-on="org.apache.cxf.transport.http.ClientOnlyHTTPTransportFactory">
>         <property name="bus" ref="cxf"/>
>         <property name="transportIds">
>             <list>
>                 <value>http://schemas.xmlsoap.org/soap/http</value>
>                 <value>http://schemas.xmlsoap.org/wsdl/http/</value>
>                 <value>http://schemas.xmlsoap.org/wsdl/soap/http</value>
>  	            <value>http://www.w3.org/2003/05/soap/bindings/HTTP/</value>
>                 <value>http://cxf.apache.org/transports/http/configuration</value>
>                 <value>http://cxf.apache.org/bindings/xformat</value>
>             </list>
>         </property>
>     </bean>
> {code}
> this is the 2.3.0 version
> {code:xml}
> <bean class="org.apache.cxf.transport.http_jetty.JettyHTTPTransportFactory"
> 	  id="org.apache.cxf.transport.http_jetty.JettyHTTPTransportFactory"
>     	lazy-init="true">
>         <property name="bus" ref="cxf"/>
>         <property name="transportIds">
>             <list>
>                 <value>http://cxf.apache.org/transports/http</value>
>                 <value>http://cxf.apache.org/transports/http/configuration</value>
>                 <value>http://schemas.xmlsoap.org/wsdl/http</value>
>                 <value>http://schemas.xmlsoap.org/wsdl/http/</value>
>             </list>
>         </property>
>     </bean>
> {code}
> Two things to notice:
> * Lazy init
> * Transport ids have changed
> Both seem to cause the issue. If I override the bean definition in a CXF 2.3 env with
the 2.2.11 version, my test passes. Flipping only the lazy init or the transport itd will
not work.
> I don't know what caused this change so let me know so that I can give you more information
about my environment.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message