cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Camus (JIRA)" <j...@apache.org>
Subject [jira] Created: (CXF-3077) java.lang.InstantiationException: org.apache.cxf.wstx_msv_validation.WoodstoxValidationImpl
Date Wed, 20 Oct 2010 10:31:31 GMT
java.lang.InstantiationException: org.apache.cxf.wstx_msv_validation.WoodstoxValidationImpl
-------------------------------------------------------------------------------------------

                 Key: CXF-3077
                 URL: https://issues.apache.org/jira/browse/CXF-3077
             Project: CXF
          Issue Type: Bug
          Components: Bus
    Affects Versions: 2.3.0
         Environment: Windows XP
JDK 1.6.0_21
            Reporter: Guillaume Camus


I try to upgrade lib from CXF 2.2.10 to 2.3.0 and I have got this exception :

{noformat}
Exception in thread "main" org.apache.cxf.bus.extension.ExtensionException
	at org.apache.cxf.bus.extension.Extension.load(Extension.java:114)
	at org.apache.cxf.bus.extension.ExtensionManagerImpl.loadAndRegister(ExtensionManagerImpl.java:183)
	at org.apache.cxf.bus.extension.ExtensionManagerImpl.processExtension(ExtensionManagerImpl.java:158)
	at org.apache.cxf.bus.extension.ExtensionManagerImpl.loadFragment(ExtensionManagerImpl.java:151)
	at org.apache.cxf.bus.extension.ExtensionManagerImpl.load(ExtensionManagerImpl.java:143)
	at org.apache.cxf.bus.extension.ExtensionManagerImpl.load(ExtensionManagerImpl.java:96)
	at org.apache.cxf.bus.extension.ExtensionManagerBus.<init>(ExtensionManagerBus.java:129)
	at org.apache.cxf.bus.CXFBusFactory.createBus(CXFBusFactory.java:41)
	at org.apache.cxf.bus.CXFBusFactory.createBus(CXFBusFactory.java:37)
	at org.apache.cxf.bus.CXFBusFactory.createBus(CXFBusFactory.java:33)
	at org.apache.cxf.BusFactory.getDefaultBus(BusFactory.java:72)
	at org.apache.cxf.BusFactory.getThreadDefaultBus(BusFactory.java:115)
	at org.apache.cxf.BusFactory.getThreadDefaultBus(BusFactory.java:102)
	at org.apache.cxf.jaxws.spi.ProviderImpl.createServiceDelegate(ProviderImpl.java:89)
	at javax.xml.ws.Service.<init>(Service.java:56)
	(...)
Caused by: java.lang.InstantiationException: org.apache.cxf.wstx_msv_validation.WoodstoxValidationImpl
	at java.lang.Class.newInstance0(Class.java:340)
	at java.lang.Class.newInstance(Class.java:308)
	at org.apache.cxf.bus.extension.Extension.load(Extension.java:110)
{noformat}

This exception is throwed when I access to my webservice (webservice using CXF 2.3.0 under
Tomcat 6.0).

My consumer was written following this doc :
http://cxf.apache.org/docs/developing-a-consumer.html
# My WSDL is saved on a file.
# I generate the stub code with wsdl2java with this WSDL (with new CXF 2.3.0)
# I call methods that work with older CXF release.

I use these libs :
* cxf-2.3.0.jar
* jcl-over-slf4j-1.6.1.jar
* log4j-1.2.16.jar
* neethi-2.0.4.jar
* slf4j-api-1.6.1.jar
* slf4j-log4j12-1.6.1.jar
* wsdl4j-1.6.2.jar
* XmlSchema-1.4.7.jar

I try to add these libs without success :
* woodstox-core-asl-4.0.8.jar
* stax2-api-3.0.2.jar

I tried with CXF 2.3.1 Snapshot (build on 20 october 2010) and i have the same exception.
I tried with CXF 2.2.11 and my consumer work correctly.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message