cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Leamon (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CXF-3095) Jax WS - Schema Locations are ignored since CXF-2851 was implemented
Date Thu, 28 Oct 2010 01:39:21 GMT

     [ https://issues.apache.org/jira/browse/CXF-3095?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Patrick Leamon updated CXF-3095:
--------------------------------

          Description: 
I'm having very odd schema validation issues since moving from cxf 2.0.11 to cxf 2.2.10.

The beans.xml I'm using to configure the web service looks something like:
{code:xml}
    <jaxws:endpoint id="LocationServiceId"
                    implementor="com.blah.LocationServiceImpl"
                    address="/services/location">
        <jaxws:properties>
            <entry key="schema-validation-enabled" value="true" />
        </jaxws:properties>
        <jaxws:schemaLocations>
            <jaxws:schemaLocation>classpath:xsd/common-types.xsd</jaxws:schemaLocation>
            <jaxws:schemaLocation>classpath:xsd/location-types..xsd</jaxws:schemaLocation>
            <jaxws:schemaLocation>classpath:xsd/location-service.xsd</jaxws:schemaLocation>
        </jaxws:schemaLocations>
    </jaxws:endpoint>
{code}

The first five requests that I send to this web service function correctly.  Any further requests
result in:
Unmarshalling Error: cvc-elt.1: Cannot find the declaration of element 'ns1:locationElement'

Previously in 2.0.11 this was working fine, regardless of the number of requests being sent.

*edit* Reverting to 2.2.9 works perfectly.  It looks like the code path that reads in schemaLocations
was disabled by the fix to CXF-2851.

  was:
I'm having very odd schema validation issues since moving from cxf 2.0.11 to cxf 2.2.10.

The beans.xml I'm using to configure the web service looks something like:
{code:xml}
    <jaxws:endpoint id="LocationServiceId"
                    implementor="com.blah.LocationServiceImpl"
                    address="/services/location">
        <jaxws:properties>
            <entry key="schema-validation-enabled" value="true" />
        </jaxws:properties>
        <jaxws:schemaLocations>
            <jaxws:schemaLocation>classpath:xsd/common-types.xsd</jaxws:schemaLocation>
            <jaxws:schemaLocation>classpath:xsd/location-types..xsd</jaxws:schemaLocation>
            <jaxws:schemaLocation>classpath:xsd/location-service.xsd</jaxws:schemaLocation>
        </jaxws:schemaLocations>
    </jaxws:endpoint>
{code}

The first five requests that I send to this web service function correctly.  Any further requests
result in:
Unmarshalling Error: cvc-elt.1: Cannot find the declaration of element 'ns1:locationElement'

Previously in 2.0.11 this was working fine, regardless of the number of requests being sent.

    Affects Version/s: 2.2.11
              Summary: Jax WS - Schema Locations are ignored since CXF-2851 was implemented
 (was: Jax WS - Schema validation fails after 5th request)

> Jax WS - Schema Locations are ignored since CXF-2851 was implemented
> --------------------------------------------------------------------
>
>                 Key: CXF-3095
>                 URL: https://issues.apache.org/jira/browse/CXF-3095
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.2.10, 2.2.11
>         Environment: running in tomcat 6
>            Reporter: Patrick Leamon
>
> I'm having very odd schema validation issues since moving from cxf 2.0.11 to cxf 2.2.10.
> The beans.xml I'm using to configure the web service looks something like:
> {code:xml}
>     <jaxws:endpoint id="LocationServiceId"
>                     implementor="com.blah.LocationServiceImpl"
>                     address="/services/location">
>         <jaxws:properties>
>             <entry key="schema-validation-enabled" value="true" />
>         </jaxws:properties>
>         <jaxws:schemaLocations>
>             <jaxws:schemaLocation>classpath:xsd/common-types.xsd</jaxws:schemaLocation>
>             <jaxws:schemaLocation>classpath:xsd/location-types..xsd</jaxws:schemaLocation>
>             <jaxws:schemaLocation>classpath:xsd/location-service.xsd</jaxws:schemaLocation>
>         </jaxws:schemaLocations>
>     </jaxws:endpoint>
> {code}
> The first five requests that I send to this web service function correctly.  Any further
requests result in:
> Unmarshalling Error: cvc-elt.1: Cannot find the declaration of element 'ns1:locationElement'
> Previously in 2.0.11 this was working fine, regardless of the number of requests being
sent.
> *edit* Reverting to 2.2.9 works perfectly.  It looks like the code path that reads in
schemaLocations was disabled by the fix to CXF-2851.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message