cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CXF-2216) CXF Import-Package version specifiers causes 'uses' conflict
Date Thu, 17 Dec 2009 22:24:18 GMT

     [ https://issues.apache.org/jira/browse/CXF-2216?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Kulp resolved CXF-2216.
------------------------------

       Resolution: Fixed
    Fix Version/s: 2.2.6
         Assignee: Daniel Kulp


Stuck version ranges of [0.0,#) on the javax* stuff.

> CXF Import-Package version specifiers causes 'uses' conflict
> ------------------------------------------------------------
>
>                 Key: CXF-2216
>                 URL: https://issues.apache.org/jira/browse/CXF-2216
>             Project: CXF
>          Issue Type: Bug
>          Components: OSGi
>    Affects Versions: 2.2.1
>         Environment: Equinox
>            Reporter: Hendy Irawan
>            Assignee: Daniel Kulp
>             Fix For: 2.2.6
>
>         Attachments: config.ini
>
>
> Equinox exports system packages as version=0.0.0. CXF bundle (and CXF bundle jaxrs) imports
some of these packages as specific versions. This causes problems because:
>    * Application Developer has to provide bundles for these packages instead of letting
CXF use the packages that Equinox exports
>    * When another bundle uses a system package specifying version=0.0.0, for example
javax.mail;version=1.4.0 uses javax.activation;version=0.0.0, this causes "uses" conflict
because CXF uses javax.mail;version=1.4.0 and javax.activation;version=1.0
>    * My workaround was to patch the CXF jar manifest.mf to remove version specifiers
in some packages it imports
> I've identified 5 packages that need to have its version specifier left out in CXF's
Import-Package in order for my app to work:
>     * javax.activation
>     * javax.annotation
>     * javax.xml.stream
>     * javax.xml.stream.events
>     * javax.xml.stream.util
> I'd vote for these import-packages to have no version specifier as well:
>    * javax.resource
>    * javax.resource.spi
> Thanks.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message