cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-2039) -Dorg.apache.cxf.spring.validation.mode=VALIDATION_NONE has no effect
Date Thu, 26 Feb 2009 21:41:01 GMT

    [ https://issues.apache.org/jira/browse/CXF-2039?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12677152#action_12677152
] 

Daniel Kulp commented on CXF-2039:
----------------------------------


Can you pass the full stack trace?

That property only applies when it's CXF code actually creating the Application context. 
  If something else is creating the Application context (like the webapp listener thing),
that flag doesn't apply.   It would be up to whatever is creating the context to provide the
flags or whatever necessary to turn off the validation.


> -Dorg.apache.cxf.spring.validation.mode=VALIDATION_NONE has no effect
> ---------------------------------------------------------------------
>
>                 Key: CXF-2039
>                 URL: https://issues.apache.org/jira/browse/CXF-2039
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.1.4
>         Environment: win32, cxf2.1.4 or cxf2.1.3
>            Reporter: Laurent Perez
>
> Hi
> Following CXF-1647 (and http://cwiki.apache.org/CXF20DOC/schemas-and-namespaces.html),
I've tried setting a org.apache.cxf.spring.validation.mode=VALIDATION_NONE property in order
to configure timeouts via spring properties, as in :
> <http-conf:client ConnectionTimeout="${ws.auth.connectionTimeout}" ReceiveTimeout="${ws.auth.receiveTimeout}"/>
> However, the property has no effect, I still get (1) when using a mvn jetty:run :
> What I've tried :
> - command line, set MAVEN_OPTS="-Dorg.apache.cxf.spring.validation.mode=VALIDATION_NONE"
> - pom.xml, jetty configuration : 					<systemProperties> <systemProperty>
<name>org.apache.cxf.spring.validation.mode</name><value>VALIDATION_NONE</value>
</systemProperty></systemProperties>
> - both have no effect
> Is the property supposed to be used like this ?
> Thanks
> (1)
> Offending resource: ServletContext resource [/WEB-INF/applicationContext.xml]; n
> ested exception is org.springframework.beans.factory.xml.XmlBeanDefinitionStoreE
> xception: Line 43 in XML document from class path resource [ws-context.xml] is i
> nvalid; nested exception is org.xml.sax.SAXParseException: cvc-datatype-valid.1.
> 2.1: '${ws.auth.connectionTimeout}' is not a valid value for 'integer'.:
> org.xml.sax.SAXParseException: cvc-datatype-valid.1.2.1: '${ws.auth.connectionTi
> meout}' is not a valid value for 'integer'.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message