cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sripathi Acharya (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CXF-1750) CXF 2.1.1 And WebLogic 10
Date Fri, 10 Oct 2008 17:21:44 GMT

     [ https://issues.apache.org/jira/browse/CXF-1750?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sripathi Acharya resolved CXF-1750.
-----------------------------------

    Resolution: Fixed

Since Weblogic uses JAX-WS 2.0 and CXF requires JAX-WS 2.1 we need to override the package
javax.xml.ws.*

Modify the weblogic-application.xml as follows

<?xml version="1.0" encoding="UTF-8"?> 
<weblogic-application xmlns="http://www.bea.com/ns/weblogic/90"> 
    <application-param> 
        <param-name>webapp.encoding.default</param-name> 
        <param-value>UTF-8</param-value> 
    </application-param> 
    <prefer-application-packages> 
        <package-name>javax.jws.*</package-name>
        <package-name>javax.xml.ws.*</package-name>
        <package-name>org.apache.cxf.*</package-name>
        <package-name>antlr.*</package-name>
    </prefer-application-packages> 
</weblogic-application> 

> CXF 2.1.1 And WebLogic 10
> -------------------------
>
>                 Key: CXF-1750
>                 URL: https://issues.apache.org/jira/browse/CXF-1750
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.1.1
>         Environment: WebLogic 10
>            Reporter: Sripathi Acharya
>
> Hi All,
> I'm facing the following exception when I build the webservice from the CXF sample hello_world.wsdl
and try to deploy on WebLogic 10
> <Aug 15, 2008 12:20:34 PM BST> <Error> <HTTP> <BEA-101125> <[weblogic.servlet.internal.WebAppServletContext@14627f
- appName: 'HelloWorld', name: 'HelloWorldWeb', context-path: '/HelloWorldWeb'] Error occurred
while instantiating servlet: "org.apache.cxf.js.rhino.DOMPayloadProvider".
> java.lang.InstantiationException: org.apache.cxf.js.rhino.DOMPayloadProvider
>         at java.lang.Class.newInstance0(Class.java:335)
>         at java.lang.Class.newInstance(Class.java:303)
>         at weblogic.servlet.internal.WebComponentContributor.getNewInstance(WebComponentContributor.java:187)
>         at weblogic.servlet.internal.WebComponentContributor.createServletInstance(WebComponentContributor.java:203)
>         at weblogic.servlet.internal.StubSecurityHelper$ServletInitAction.run(StubSecurityHelper.java:254)
> I've used CXF wsdl2java converter to build the server side code.
> My EAR model is as follows:
> HelloWorld.ear
>     -META-INF
>         -weblogic-application.xml
>     -HelloWorldWeb.war
>         -wsdl
>             -hello_world.wsdl
>         -WEB-INF
>             -lib
>             -classes
>             -web.xml
>             -bean.xml
> The bean XML has the following entry:
> 	<import resource="classpath:META-INF/cxf/cxf.xml" />
> 	<import resource="classpath:META-INF/cxf/cxf-extension-soap.xml" />
> 	<import resource="classpath:META-INF/cxf/cxf-servlet.xml" />
> 	<jaxws:endpoint id="HelloWorld"
> 		implementor="org.apache.hello_world_soap_http.GreeterImpl"
> 		address="/HelloWorld">
> 	</jaxws:endpoint>
> weblogic-application.xml has the following entry:
>     <application-param>
>         <param-name>webapp.encoding.default</param-name>
>         <param-value>UTF-8</param-value>
>     </application-param>
>     <prefer-application-packages>
>         <package-name>javax.jws.*</package-name>
>     </prefer-application-packages> 
> Workaround:
> I've modified the DOMPayloadProvider source to include default constructor, which allowed
me to deploy the application on to WebLogic 10.
> P.S. The application works fine on Tomcat 6.0

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message