cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadrian Zbarcea (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CXF-1792) JMX ONs for performance counters should not use qnames for port and operation
Date Thu, 11 Sep 2008 02:28:44 GMT

     [ https://issues.apache.org/jira/browse/CXF-1792?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hadrian Zbarcea updated CXF-1792:
---------------------------------

    Description: 
ObjectNames for counters look like that:

org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="{http://apache.org/hello_world_soap_http}SOAPService",port="{http://apache.org/hello_world_soap_http}SoapPort",operation="{http://apache.org/hello_world_soap_http}sayHi"

Having them mapped to qnames is unnecessary and only makes ONs long and hard to read/manage
and I think it would be better if they looked like this:

org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="{http://apache.org/hello_world_soap_http}SOAPService",port="SoapPort",operation="sayHi"


I am proposing the attached patch to fix this. 

  was:
ObjectNames for counters look like that:

org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="{http://apache.org/hello_world_soap_http}SOAPService",port="{http://apache.org/hello_world_soap_http}SoapPort,operation="{http://apache.org/hello_world_soap_http}sayHi"

Having them mapped to qnames is unnecessary and only makes ONs long and hard to read/manage.
 I am proposing the attached patch to fix this. 


> JMX ONs for performance counters should not use qnames for port and operation
> -----------------------------------------------------------------------------
>
>                 Key: CXF-1792
>                 URL: https://issues.apache.org/jira/browse/CXF-1792
>             Project: CXF
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.1.2
>            Reporter: Hadrian Zbarcea
>         Attachments: cxf-1792.patch
>
>
> ObjectNames for counters look like that:
> org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="{http://apache.org/hello_world_soap_http}SOAPService",port="{http://apache.org/hello_world_soap_http}SoapPort",operation="{http://apache.org/hello_world_soap_http}sayHi"
> Having them mapped to qnames is unnecessary and only makes ONs long and hard to read/manage
and I think it would be better if they looked like this:
> org.apache.cxf:bus.id=cxf945122723,type=Performance.Counter.Server,service="{http://apache.org/hello_world_soap_http}SOAPService",port="SoapPort",operation="sayHi"
> I am proposing the attached patch to fix this. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message