cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glen Mazza (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-1750) CXF 2.1.1 And WebLogic 10
Date Tue, 19 Aug 2008 01:09:44 GMT

    [ https://issues.apache.org/jira/browse/CXF-1750?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12623520#action_12623520
] 

Glen Mazza commented on CXF-1750:
---------------------------------

Sorry, don't think I can help you here.  It appears then that DOMPayloadProvider and/or DOMMessageProvider
are calling libraries that WebLogic supplies by default, and those libraries that are either
older or newer than the ones CXF ships with.  

WebLogic unfortunately uses its own libraries unless you explicitly add them to <prefer
application packages/>  -- that is what triggers the CXF-bundled libraries to be used.
 I don't know of an easy way to figure out what those libraries are--view error stack traces,
perhaps.

As far as I'm concerned, if we work on Tomcat it is not a CXF bug.  It is not the CXF project's
fault if an app server wrongly swaps out the JARs that CXF is packaged with and replaces them
with its own.  But if you can find out more information, please leave a comment here so others
can be helped.


> CXF 2.1.1 And WebLogic 10
> -------------------------
>
>                 Key: CXF-1750
>                 URL: https://issues.apache.org/jira/browse/CXF-1750
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.1.1
>         Environment: WebLogic 10
>            Reporter: Sripathi Acharya
>
> Hi All,
> I'm facing the following exception when I build the webservice from the CXF sample hello_world.wsdl
and try to deploy on WebLogic 10
> <Aug 15, 2008 12:20:34 PM BST> <Error> <HTTP> <BEA-101125> <[weblogic.servlet.internal.WebAppServletContext@14627f
- appName: 'HelloWorld', name: 'HelloWorldWeb', context-path: '/HelloWorldWeb'] Error occurred
while instantiating servlet: "org.apache.cxf.js.rhino.DOMPayloadProvider".
> java.lang.InstantiationException: org.apache.cxf.js.rhino.DOMPayloadProvider
>         at java.lang.Class.newInstance0(Class.java:335)
>         at java.lang.Class.newInstance(Class.java:303)
>         at weblogic.servlet.internal.WebComponentContributor.getNewInstance(WebComponentContributor.java:187)
>         at weblogic.servlet.internal.WebComponentContributor.createServletInstance(WebComponentContributor.java:203)
>         at weblogic.servlet.internal.StubSecurityHelper$ServletInitAction.run(StubSecurityHelper.java:254)
> I've used CXF wsdl2java converter to build the server side code.
> My EAR model is as follows:
> HelloWorld.ear
>     -META-INF
>         -weblogic-application.xml
>     -HelloWorldWeb.war
>         -wsdl
>             -hello_world.wsdl
>         -WEB-INF
>             -lib
>             -classes
>             -web.xml
>             -bean.xml
> The bean XML has the following entry:
> 	<import resource="classpath:META-INF/cxf/cxf.xml" />
> 	<import resource="classpath:META-INF/cxf/cxf-extension-soap.xml" />
> 	<import resource="classpath:META-INF/cxf/cxf-servlet.xml" />
> 	<jaxws:endpoint id="HelloWorld"
> 		implementor="org.apache.hello_world_soap_http.GreeterImpl"
> 		address="/HelloWorld">
> 	</jaxws:endpoint>
> weblogic-application.xml has the following entry:
>     <application-param>
>         <param-name>webapp.encoding.default</param-name>
>         <param-value>UTF-8</param-value>
>     </application-param>
>     <prefer-application-packages>
>         <package-name>javax.jws.*</package-name>
>     </prefer-application-packages> 
> Workaround:
> I've modified the DOMPayloadProvider source to include default constructor, which allowed
me to deploy the application on to WebLogic 10.
> P.S. The application works fine on Tomcat 6.0

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message