cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Kieselhorst (JIRA)" <j...@apache.org>
Subject [jira] Created: (CXF-1633) http conduit authorization not applied in spring configuration with simple:client
Date Thu, 05 Jun 2008 14:57:45 GMT
http conduit authorization not applied in spring configuration with simple:client
---------------------------------------------------------------------------------

                 Key: CXF-1633
                 URL: https://issues.apache.org/jira/browse/CXF-1633
             Project: CXF
          Issue Type: Bug
          Components: Configuration
    Affects Versions: 2.1
         Environment: Tomcat 6, JDK 1.5
            Reporter: Dennis Kieselhorst
            Priority: Critical


Similar to issue CXF-922. 

Spring configuration with simple:client:
<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:simple="http://cxf.apache.org/simple"
      xmlns:sec="http://cxf.apache.org/configuration/security"
      xmlns:http="http://cxf.apache.org/transports/http/configuration"
      xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd
  http://cxf.apache.org/simple http://cxf.apache.org/schemas/simple.xsd
  http://cxf.apache.org/configuration/security http://cxf.apache.org/schemas/configuration/security.xsd
  http://cxf.apache.org/transports/http/configuration http://cxf.apache.org/schemas/configuration/http-conf.xsd">

  <simple:client id="cxf-client"
  	address="http://localhost:8080/webservices/MyService"
  	serviceClass="de.my.service.MyService">
  	<simple:dataBinding>
  		<bean class="org.apache.cxf.aegis.databinding.AegisDatabinding" />
  	</simple:dataBinding>
  </simple:client>

  <http:conduit name="{http://service.my.de/}MyServicePort.http-conduit">
  	<http:authorization>
  		<sec:UserName>myTestuser</sec:UserName>
  		<sec:Password>myTestpassword</sec:Password>
  	</http:authorization>
  </http:conduit>
</beans>

Also tried the wildcard solution explained here - http://cwiki.apache.org/CXF20DOC/client-http-transport-including-ssl-support.html:
  <http:conduit name="*.http-conduit">
  	<http:authorization>
  		<sec:UserName>myTestuser</sec:UserName>
  		<sec:Password>myTestpassword</sec:Password>
  	</http:authorization>
  </http:conduit>

AuthorizationPolicy exists, but userName and password are null (see screenshot).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message