cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gianfranco Boccalon (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CXF-1496) Wrong content type produced by CXF BC provider
Date Wed, 02 Apr 2008 14:47:27 GMT

     [ https://issues.apache.org/jira/browse/CXF-1496?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gianfranco Boccalon updated CXF-1496:
-------------------------------------

    Description: 
I found a problem on the CXF BC provider: I'm sending a MTOM/XOP message and I found an error
on the content type of the first SOAP part (the one containing the SOAP envelope).

As you can see the attribute "type" of the part contains also the attributes action and charset
within the "":

------=_Part_0_20040450.1206892450875

Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml; action="urn:ihe:iti:2007:RetrieveDocumentSet";
charset=UTF-8"


The correct value for the attribute should be:

------=_Part_0_20040450.1206892450875

Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml";

I found the problem in the class org.apache.cxf.attachment.AttachmentSerializer in the method
writeProlog().
The code that produces the problem is:

       mimeBodyCt.append("application/xop+xml; charset=")
       .append(enc)
       .append("; type=\"")
       .append(bodyCt)
       .append("; charset=")
       .append(enc)
       .append("\"");


while it should be:

       mimeBodyCt.append("application/xop+xml; charset=")
           .append(enc)
           .append("; type=\"")
           .append(bodyCt)
           .append("\";");

I found a similar problem on the header of the SOAP request, on the attribute start-info:

Content-Type: multipart/related; type="application/xop+xml"; boundary="----=_Part_0_20040450.1206892450875";
start="<root.message@cxf.apache.org>"; start-info="application/soap+xml; action="urn:ihe:iti:2007:RetrieveDocumentSet""

it should be:

Content-Type: multipart/related; type="application/xop+xml"; boundary="----=_Part_0_20040450.1206892450875";
start="<root.message@cxf.apache.org>"; start-info="application/soap+xml"; action="urn:ihe:iti:2007:RetrieveDocumentSet"


The problem is aways on the same class.
The problem occurs also on the response messages of the CXF BC Consumer.


  was:
I found a problem on the CXF BC provider: I'm sending a MTOM/XOP message and I found an error
on the content type of the first SOAP part (the one containing the SOAP envelope).

As you can see the attribute "type" of the part contains also the attributes action and charset
within the "":

------=_Part_0_20040450.1206892450875

Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml; action="urn:ihe:iti:2007:RetrieveDocumentSet";
charset=UTF-8"


The correct value for the attribute should be:

------=_Part_0_20040450.1206892450875

Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml";

I found the problem in the class org.apache.cxf.attachment.AttachmentSerializer in the method
writeProlog().
The code that produces the problem is:

       mimeBodyCt.append("application/xop+xml; charset=")
       .append(enc)
       .append("; type=\"")
       .append(bodyCt)
       .append("; charset=")
       .append(enc)
       .append("\"");


while it should be:

       mimeBodyCt.append("application/xop+xml; charset=")
           .append(enc)
           .append("; type=\"")
           .append(bodyCt)
           .append("\";");

I found a similar problem on the header of the SOAP request, on the attribute start-info:

Content-Type: multipart/related; type="application/xop+xml"; boundary="----=_Part_0_20040450.1206892450875";
start="<root.message@cxf.apache.org>"; start-info="application/soap+xml; action="urn:ihe:iti:2007:RetrieveDocumentSet""

it should be:

Content-Type: multipart/related; type="application/xop+xml"; boundary="----=_Part_0_20040450.1206892450875";
start="<root.message@cxf.apache.org>"; start-info="application/soap+xml"; action="urn:ihe:iti:2007:RetrieveDocumentSet"


The problem is aways on the same class.



> Wrong content type produced by CXF BC provider
> ----------------------------------------------
>
>                 Key: CXF-1496
>                 URL: https://issues.apache.org/jira/browse/CXF-1496
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.0.2
>            Reporter: Gianfranco Boccalon
>         Attachments: AttachmentSerializer.java.diff
>
>
> I found a problem on the CXF BC provider: I'm sending a MTOM/XOP message and I found
an error on the content type of the first SOAP part (the one containing the SOAP envelope).
> As you can see the attribute "type" of the part contains also the attributes action and
charset within the "":
> ------=_Part_0_20040450.1206892450875
> Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml; action="urn:ihe:iti:2007:RetrieveDocumentSet";
charset=UTF-8"
> The correct value for the attribute should be:
> ------=_Part_0_20040450.1206892450875
> Content-Type: application/xop+xml; charset=UTF-8; type="application/soap+xml";
> I found the problem in the class org.apache.cxf.attachment.AttachmentSerializer in the
method writeProlog().
> The code that produces the problem is:
>        mimeBodyCt.append("application/xop+xml; charset=")
>        .append(enc)
>        .append("; type=\"")
>        .append(bodyCt)
>        .append("; charset=")
>        .append(enc)
>        .append("\"");
> while it should be:
>        mimeBodyCt.append("application/xop+xml; charset=")
>            .append(enc)
>            .append("; type=\"")
>            .append(bodyCt)
>            .append("\";");
> I found a similar problem on the header of the SOAP request, on the attribute start-info:
> Content-Type: multipart/related; type="application/xop+xml"; boundary="----=_Part_0_20040450.1206892450875";
start="<root.message@cxf.apache.org>"; start-info="application/soap+xml; action="urn:ihe:iti:2007:RetrieveDocumentSet""
> it should be:
> Content-Type: multipart/related; type="application/xop+xml"; boundary="----=_Part_0_20040450.1206892450875";
start="<root.message@cxf.apache.org>"; start-info="application/soap+xml"; action="urn:ihe:iti:2007:RetrieveDocumentSet"
> The problem is aways on the same class.
> The problem occurs also on the response messages of the CXF BC Consumer.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message