cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-1448) Aegis DataBinding Problem - "Error initializing parameters for operation"
Date Thu, 28 Feb 2008 17:15:51 GMT

    [ https://issues.apache.org/jira/browse/CXF-1448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12573361#action_12573361
] 

Daniel Kulp commented on CXF-1448:
----------------------------------

Ben,

I sent a note to Benson that described some extra stuff that would be useful to help debug
this.   Basically:

1) Can you add the Logging interceptor to the servers side in chain?  (client side chains
would be nice too)  If we can see the faulty soap message, we can then at least tell if its
the client sending a bad message or the server having problems parsing it.

2) On the server side, could you NOT add the ws-security stuff and just add the SAAJInInterceptor
and see if the problem remains.  The stack trace implies that it should still be problematic.
  This plus the soap message would be a huge step in helping to debug it as it removes the
ws-security complexities.

As Benson said, though, a full test case in a nice zip with either an ant build.xml or maven
pom (can use jetty:run or something) that shows the issue with a simple war in tomcat or standalone
would be a HUGE help.   Once we have a simple, completely reproducable test case, these fixes
are NORMALLY fairly quick to fix.   It's creating the test case that's the hard part as we
don't know exactly what you are doing, how you have things configured, etc...

Thanks!

> Aegis DataBinding Problem - "Error initializing parameters for operation"
> -------------------------------------------------------------------------
>
>                 Key: CXF-1448
>                 URL: https://issues.apache.org/jira/browse/CXF-1448
>             Project: CXF
>          Issue Type: Bug
>          Components: Aegis Databinding
>    Affects Versions: 2.0.4
>         Environment: I am running WebLogic 9.2.2 on Windows XP
>            Reporter: Ben McCann
>            Assignee: Benson Margulies
>             Fix For: 2.0.5
>
>         Attachments: AuthService.java, AuthServiceImpl.java, AuthServiceImpl.java, cxf.xml,
Employee.java, Employee.java, stackTrace.log, stackTraceAegisWSSecurity.log, stackTraceWithSetCommentedOut.log
>
>
> Hi,
> I am getting "Error initializing parameters for operation" from Aegis.  I set it up through
Spring.  My classes mostly just use String, so I'm not sure what the problem is.
> Thanks,
> Ben 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message