cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben McCann (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (CXF-1448) Aegis DataBinding Problem - "Error initializing parameters for operation"
Date Wed, 27 Feb 2008 19:55:51 GMT

    [ https://issues.apache.org/jira/browse/CXF-1448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12573051#action_12573051
] 

chengas123 edited comment on CXF-1448 at 2/27/08 11:55 AM:
-----------------------------------------------------------

I found the simple server xmlns and added that to get a bit further, but it looks like I can't
have security on that, so I went back to the JAX-WS and got that working now!  
I guess I didn't realize that Aegis would have to be implemented on both ends, though it makes
sense.  And I'm sure JAXB could probably be used on one end still, but that seems like it's
be extra work.
Not out of the woods yet though!   If I try using WS-Security with Aegis I get an error, which
I am attaching the stack trace for.

      was (Author: chengas123):
    I found the simple server xmlns and added that to get a bit further, but it looks like
I can't have security on that, so I went back to the JAX-WS and got that working now!  I guess
I didn't realize that Aegis would have to be implemented on both ends though it makes sense.
 And I'm sure JAXB could probably be used on one end still, but that seems like it's be extra
work.
Not out of the woods yet though!   If I try using WS-Security with Aegis I get an error, which
I am attaching the stack trace for.
  
> Aegis DataBinding Problem - "Error initializing parameters for operation"
> -------------------------------------------------------------------------
>
>                 Key: CXF-1448
>                 URL: https://issues.apache.org/jira/browse/CXF-1448
>             Project: CXF
>          Issue Type: Bug
>          Components: Aegis Databinding
>    Affects Versions: 2.0.4
>         Environment: I am running WebLogic 9.2.2 on Windows XP
>            Reporter: Ben McCann
>            Assignee: Benson Margulies
>             Fix For: 2.0.5
>
>         Attachments: AuthService.java, AuthServiceImpl.java, AuthServiceImpl.java, cxf.xml,
Employee.java, Employee.java, stackTrace.log, stackTraceAegisWSSecurity.log, stackTraceWithSetCommentedOut.log
>
>
> Hi,
> I am getting "Error initializing parameters for operation" from Aegis.  I set it up through
Spring.  My classes mostly just use String, so I'm not sure what the problem is.
> Thanks,
> Ben 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message