cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benson Margulies (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-1448) Aegis DataBinding Problem - "Error initializing parameters for operation"
Date Sun, 24 Feb 2008 20:15:14 GMT

    [ https://issues.apache.org/jira/browse/CXF-1448?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12571937#action_12571937
] 

Benson Margulies commented on CXF-1448:
---------------------------------------

Staring at your backtrace, I see something. I actually see a couple of things.

The exception is being thrown by a weblogic class, which is complaining that you can't get
a prefix for an empty namespace. I'm not sure that they are correct.

Still, I also can't repro the empty namespace. When I breakpoint in the ElementWriter, we've
always got one. I don't see any reason why I should have any more namespaces than you have
if, indeed, you have no .aegis.xml files.

Meanwhile, it also looks to me as if you have the org.apache.cxf.aegis.databinding.AegisServiceConfiguration
on your server and not on your client. This can lead to namespace mismatches, as all it does
is add / characters to default namespaces. I recommend not using it at all, but if  you must,
use it on both ends.

Are you willing to set up a CXF build at set a breakpoint? Or to download a 2.1 snapshot?
I'm debugging against the 2.1 trunk.



> Aegis DataBinding Problem - "Error initializing parameters for operation"
> -------------------------------------------------------------------------
>
>                 Key: CXF-1448
>                 URL: https://issues.apache.org/jira/browse/CXF-1448
>             Project: CXF
>          Issue Type: Bug
>          Components: Aegis Databinding
>    Affects Versions: 2.0.4
>         Environment: I am running WebLogic 9.2.2 on Windows XP
>            Reporter: Ben McCann
>            Assignee: Benson Margulies
>             Fix For: 2.0.5
>
>         Attachments: AuthService.java, AuthServiceImpl.java, AuthServiceImpl.java, cxf.xml,
Employee.java, Employee.java, stackTrace.log, stackTraceWithSetCommentedOut.log
>
>
> Hi,
> I am getting "Error initializing parameters for operation" from Aegis.  I set it up through
Spring.  My classes mostly just use String, so I'm not sure what the problem is.
> Thanks,
> Ben 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message