cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benson Margulies (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-1396) Aegis and java2ws results in strange schema errors
Date Fri, 18 Jan 2008 00:32:34 GMT

    [ https://issues.apache.org/jira/browse/CXF-1396?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12560178#action_12560178
] 

Benson Margulies commented on CXF-1396:
---------------------------------------

This is a recent phenomenon. A slightly older snapshot of 2.1 does not run into this.


> Aegis and java2ws results in strange schema errors
> --------------------------------------------------
>
>                 Key: CXF-1396
>                 URL: https://issues.apache.org/jira/browse/CXF-1396
>             Project: CXF
>          Issue Type: Bug
>          Components: Aegis Databinding
>            Reporter: Benson Margulies
>            Assignee: Benson Margulies
>             Fix For: 2.1
>
>
> In my application, when I try to run java2ws, I get:
> JavaToJS Error : java.lang.RuntimeException: Schema for namespace 'http://demo1.searchtools.basistech.com'
already contains type 'argument
> The RuntimeException results directly from XML Schema, complaining about a name conflict
on types.
> However, if I pull the wsdl with ?wsdl, there are no types at all named 'argument'.
> Thus I reason that the internally generated XML is quite different. I'm using aegis as
a data binding.
> I fear that something is wrong with the code for java2 for aegis.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message