cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-1390) Upgrade to Spring 2.5
Date Mon, 14 Jan 2008 18:53:34 GMT

    [ https://issues.apache.org/jira/browse/CXF-1390?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12558725#action_12558725
] 

Daniel Kulp commented on CXF-1390:
----------------------------------


Just to clarify:

I don't think for 2.0.4 we should force everyone to upgrade to spring 2.5.   However, making
it work with both 2.0.x and 2.5 would be good.   

Thoughts?

> Upgrade to Spring 2.5
> ---------------------
>
>                 Key: CXF-1390
>                 URL: https://issues.apache.org/jira/browse/CXF-1390
>             Project: CXF
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.0.3
>            Reporter: Dan Diephouse
>             Fix For: 2.0.4
>
>
> CXF doesn't work correctly on Spring 2.5. For instance, you get this:
> org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean
with name 'jrulesService': Unsatisfied dependency expressed through constructor argument with
index 2 of type [org.apache.cxf.jaxws.JaxWsServerFactoryBean]: Ambiguous constructor argument
types - did you specify the correct bean references as constructor arguments?
> (What ever happened to the famed backward compatability!? :-) *sigh*) 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message