cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Zhang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CXF-1285) split manifest jar, not use jaxws jars included in jdk1.6
Date Fri, 14 Dec 2007 09:16:44 GMT

    [ https://issues.apache.org/jira/browse/CXF-1285?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12551738
] 

Jeff Zhang commented on CXF-1285:
---------------------------------

For JDK 1.6 work, my idea is splitting manifest jar with 2 manifests, one contains all 3rd-party
jars which has been included in JDK1.6, and the other contains other jars.
When running demo, ant task will check jdk env. If it is jdk1.5, it use both 2 manifest jars
in the classpath. If 1.6, just use one.

We can modify distribution/manifest/pom.xml

        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-jar-plugin</artifactId>
                <configuration>
                    <finalName>cxf-manifest-incubator</finalName>
                    <archive>
                        <manifest>
                            <addClasspath>true</addClasspath>
                        </manifest>
                        <manifestEntries>
                          <!-- Add an entry for the renamed bundle jar in the distro -->
			              <Class-Path>cxf-${pom.version}.jar</Class-Path>
			            </manifestEntries>
                    </archive>
                </configuration>
            </plugin>
        </plugins>

Not and all jars in the classpath. Add the jars by name list.

> split manifest jar, not use jaxws jars included in jdk1.6
> ---------------------------------------------------------
>
>                 Key: CXF-1285
>                 URL: https://issues.apache.org/jira/browse/CXF-1285
>             Project: CXF
>          Issue Type: Sub-task
>          Components: Build system
>            Reporter: Jeff Zhang
>            Priority: Minor
>             Fix For: 2.1
>
>
> currently, cxf runtime use manifest.jar to include 3rd-party jars. Some jars like jaxws2.1,
xjc, etc.. will be packaged into jdk lib. 
> if user use CXF on jdk1.6, they can use another manifest.jar that not include these jaxws
jars
> And it need to update the tools script to check the jdk version.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message