cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 余杰 (JIRA) <j...@apache.org>
Subject [jira] Commented: (CXF-922) HTTP Conduit configuration is not loaded
Date Wed, 07 Nov 2007 06:01:51 GMT

    [ https://issues.apache.org/jira/browse/CXF-922?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12540675
] 

余杰 commented on CXF-922:
------------------------

hi,willem

thanks for your replying,but even i change the http-conduit to <http:conduit  name="*.http-conduit">,the
same exception was also been thrown.here is my configuration:

web.xml:
 <context-param>
  <param-name>contextConfigLocation</param-name>
  <param-value>/WEB-INF/client-https.xml,/WEB-INF/client-beans.xml</param-value>
 </context-param>

 <listener>
  <listener-class>
   org.springframework.web.context.ContextLoaderListener
  </listener-class>
 </listener>

client-https.xml:
 <http:conduit  name="*.http-conduit">
  <http:authorization>
   <sec:UserName>usernamehere</sec:UserName>
   <sec:Password>passwordhere</sec:Password>
  </http:authorization>
  <http:tlsClientParameters secureSocketProtocol="SSL">
  </http:tlsClientParameters>
 </http:conduit>

client-beans.xml:
 <bean id="pingClient" class="org.ets.rr.v200512.pingwebservice.PingPort"
  factory-bean="pingClientFactory" factory-method="create" />
 <bean id="pingClientFactory"
  class="org.apache.cxf.jaxws.JaxWsProxyFactoryBean">
  <property name="serviceClass" value="org.ets.rr.v200512.pingwebservice.PingPort" />
  <property name="address" value="https://server/services/PingPort" />
 </bean>

and the PingPort source code:
@WebService(targetNamespace = "http://rr.ets.org/v200512/PingWebService.wsdl", name = "PingPort")
@SOAPBinding(style = SOAPBinding.Style.RPC)

public interface PingPort {
    @WebResult(targetNamespace = "http://rr.ets.org/v200512/PingWebService.wsdl", partName
= "response", name = "response")
    @WebMethod
    public java.lang.String ping(
        @WebParam(partName = "request", name = "request")
        java.lang.String request
    );
}

is there something i miss?

____ KILL邮件安全网关 已经扫描了这封邮件 ____



> HTTP Conduit configuration is not loaded
> ----------------------------------------
>
>                 Key: CXF-922
>                 URL: https://issues.apache.org/jira/browse/CXF-922
>             Project: CXF
>          Issue Type: Bug
>          Components: Configuration
>    Affects Versions: 2.0.1
>            Reporter: Julio Arias
>            Assignee: Daniel Kulp
>             Fix For: 2.0.3
>
>
> The http conduit config is not been loaded while creating the client using spring configuration.
The conduit tlsClientParameters are never set thus the connection to a https address fails.
> This is the spring context file:
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://www.springframework.org/schema/beans"
> 	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> 	xmlns:sec="http://cxf.apache.org/configuration/security"
> 	xmlns:http="http://cxf.apache.org/transports/http/configuration"
> 	xmlns:jaxws="http://java.sun.com/xml/ns/jaxws"
> 	xsi:schemaLocation="
> 	http://cxf.apache.org/configuration/security
> 	http://cxf.apache.org/schemas/configuration/security.xsd
> 	http://cxf.apache.org/transports/http/configuration
> 	http://cxf.apache.org/schemas/configuration/http-conf.xsd
> 	http://www.springframework.org/schema/beans
> 	http://www.springframework.org/schema/beans/spring-beans-2.0.xsd">
> 	<bean id="studentWebServiceClient" class="com.ecot.crm.webservice.client.ws.student.StudentService"
factory-bean="studentWebServiceClientFactory" factory-method="create">
> 	</bean>
> 	<bean id="studentWebServiceClientFactory" class="org.apache.cxf.jaxws.JaxWsProxyFactoryBean">
> 		<property name="serviceClass" value="com.ecot.crm.webservice.client.ws.student.StudentService"/>
> 		<property name="address" value="${webservices.url}/StudentService"/>
> 	</bean>
> 	<http:conduit name="{http://client.webservice.crm.ecot.com/ws/student}StudentService.http-conduit">
> 		<http:tlsClientParameters>
> 		</http:tlsClientParameters>
> 	</http:conduit>
> </beans>
> There is also a post on the mailing list about this, the original messages is this: http://mail-archives.apache.org/mod_mbox/incubator-cxf-user/200708.mbox/%3c2D0EBEA1-B66E-47DD-A0CC-010A2F30ED48@rbxglobal.com%3e

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message