cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ronald Pieterse (JIRA)" <j...@apache.org>
Subject [jira] Created: (CXF-1127) JAXB Data Binding Generates Duplicate Fault Elements in Generated WSDL
Date Mon, 22 Oct 2007 08:55:50 GMT
JAXB Data Binding Generates Duplicate Fault Elements in Generated WSDL
----------------------------------------------------------------------

                 Key: CXF-1127
                 URL: https://issues.apache.org/jira/browse/CXF-1127
             Project: CXF
          Issue Type: Bug
          Components: JAXB Databinding
    Affects Versions: 2.0.2
            Reporter: Ronald Pieterse


In my service I have 6 calls that can throw 3 exceptionjs each. In the generated wsdl file
the exceptions are all duplicated times the number of methods.

Here's an example of a service method (they all look alike so I did just one):

@WebResult(name = "databaseFields")
public DatabaseField[] getDatabaseFields(@WebParam(name = "authInfo") AuthInfo authInfo, 
                                                                              @WebParam(name
= "databaseName") String databaseName) 
throws InvalidAuthInfoException, InvalidInputException, TripolisUnknownException;

Here's a snippet from the generated wsdl:

<xsd:schema xmlns:ns0="http://api.tripolis.com/" xmlns:tns="http://exceptions.api.tripolis.com/"
targetNamespace="http://exceptions.api.tripolis.com/" attributeFormDefault="unqualified" elementFormDefault="unqualified">
<xsd:element name="InvalidAuthInfoException" type="ns0:invalidAuthInfoFault" nillable="true"/>
<xsd:element name="TripolisUnknownException" type="ns0:tripolisUnknownFault" nillable="true"/>
<xsd:element name="InvalidInputException" type="ns0:invalidInputFault" nillable="true"/>
<xsd:element name="InvalidAuthInfoException" type="ns0:invalidAuthInfoFault" nillable="true"/>
<xsd:element name="TripolisUnknownException" type="ns0:tripolisUnknownFault" nillable="true"/>
<xsd:element name="InvalidInputException" type="ns0:invalidInputFault" nillable="true"/>
<xsd:element name="InvalidAuthInfoException" type="ns0:invalidAuthInfoFault" nillable="true"/>
...
<xsd:element name="InvalidAuthInfoException" type="ns0:invalidAuthInfoFault" nillable="true"/>
<xsd:element name="TripolisUnknownException" type="ns0:tripolisUnknownFault" nillable="true"/>
<xsd:element name="InvalidInputException" type="ns0:invalidInputFault" nillable="true"/>
</xsd:schema>

This bug might be the same as https://issues.apache.org/jira/browse/CXF-745 that was presumed
to be fixed.

Am I doing something wrong here? Or was the bug never fixed?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message