cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Genender (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CXF-536) Default namespaces with no prefixes and set are coming out empty
Date Mon, 16 Apr 2007 18:35:15 GMT

     [ https://issues.apache.org/jira/browse/CXF-536?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jeff Genender updated CXF-536:
------------------------------

    Attachment: CXF-536.jgenender.patch

> Default namespaces with no prefixes and set are coming out empty
> ----------------------------------------------------------------
>
>                 Key: CXF-536
>                 URL: https://issues.apache.org/jira/browse/CXF-536
>             Project: CXF
>          Issue Type: Bug
>          Components: Soap Binding
>    Affects Versions: 2.0
>            Reporter: Jeff Genender
>         Attachments: CXF-536.jgenender.patch
>
>
> Default name spaces with no prefixes are not handled well and any XML passed through
the W3CDOMStream(Reader/Writer) drop the default namespace.
> Example: I send...
> <Test xmlns="http://example.org/types"><argument>foobar</argument></Test>
> and when run through the reader/writer it comes out as:
> <Test xmlns=""><argument>foobar</argument></Test>
> Problem seems to be attributed to a few issues.  1) that many of the DocumentBuilder
objects do not call setNamespaceAware(true) and also an issue in processing the namespaces.
> Patch attached that fixes this along with a test case.  Many thanks to Dan Kulp, Dan
Diephouse and Jarek Gawor for helping work on this.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message