cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jimma (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CXF-303) Tools generates @WebParam/@WebResult in wrong namespace
Date Fri, 23 Mar 2007 05:59:32 GMT

     [ https://issues.apache.org/jira/browse/CXF-303?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

jimma resolved CXF-303.
-----------------------

    Resolution: Fixed

> Tools generates @WebParam/@WebResult in wrong namespace
> -------------------------------------------------------
>
>                 Key: CXF-303
>                 URL: https://issues.apache.org/jira/browse/CXF-303
>             Project: CXF
>          Issue Type: Bug
>          Components: Tooling
>    Affects Versions: 2.0-M1
>            Reporter: Dan Diephouse
>         Assigned To: jimma
>             Fix For: 2.0-RC
>
>
> If you look at the LocatorService class you'll see that the signature for the queryEndpoints
method is like this:
>     @ResponseWrapper(targetNamespace = "http://apache.org/locator/types", className =
"org.apache.cxf.testutils.locator.QueryEndpointsResponse", localName = "queryEndpointsResponse")
>     @RequestWrapper(targetNamespace = "http://apache.org/locator/types", className =
"org.apache.cxf.testutils.locator.QueryEndpoints", localName = "queryEndpoints")
>     @WebResult(targetNamespace = "http://apache.org/locator/types", name = "endpoint")
>     @WebMethod(operationName = "queryEndpoints")
>     public java.util.List<org.apache.cxf.testutils.locator.QueryEndpointsResponse.Endpoint>
queryEndpoints(
>         @WebParam(targetNamespace = "http://apache.org/locator/types", name = "select")
>         org.apache.cxf.testutils.locator.QuerySelectType select
>     );
> Looking at the schema schema you'll see that the <element name="select"> is actually
in the http://apache.org/locator/query namespace. The @WebParam should use this namespace
instead I think. The @WebParam should be in that namespace too I think.
> I ran into this while doing some refactoring. I will probably disable the LocatorServiceTest
in the short term while we get this fixed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message