cxf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tli (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (CXF-194) Fault doesn't work in xml binding
Date Thu, 02 Nov 2006 02:14:20 GMT
     [ http://issues.apache.org/jira/browse/CXF-194?page=all ]

tli reassigned CXF-194:
-----------------------

    Assignee: tli

> Fault doesn't work in xml binding
> ---------------------------------
>
>                 Key: CXF-194
>                 URL: http://issues.apache.org/jira/browse/CXF-194
>             Project: CXF
>          Issue Type: Bug
>    Affects Versions: 2.0-M1
>            Reporter: Freeman Fang
>         Assigned To: tli
>             Fix For: 2.0-M1
>
>
> when I run hello_world_xml_wrapped sample, I get exception like
>      [java] Exception in thread "main" org.apache.cxf.binding.xml.XMLFault: org.apache.hello_world_xml_http.wrapped.PingMeFault:
PingMeFault raised by server     [java]     at org.apache.cxf.binding.xml.interceptor.XMLFaultInInterceptor.handleMessage(XMLFaultInInterceptor.java:61)
>      [java]     at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:147)
>      [java]     at org.apache.cxf.interceptor.AbstractFaultChainIntiatorObserver.onMessage(AbstractFaultChainIntiatorObserver.java:75)
>      [java]     at org.apache.cxf.binding.xml.interceptor.XMLMessageInInterceptor.handleMessage(XMLMessageInInterceptor.java:85)
>      [java]     at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:147)
>      [java]     at org.apache.cxf.endpoint.ClientImpl.onMessage(ClientImpl.java:245)
>      [java]     at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponse(HTTPConduit.java:476)
>      [java]     at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.doClose(HTTPConduit.java:443)
>      [java]     at org.apache.cxf.io.AbstractCachedOutputStream.close(AbstractCachedOutputStream.java:80)
>      [java]     at org.apache.cxf.transport.http.HTTPConduit.close(HTTPConduit.java:251)
>      [java]     at org.apache.cxf.interceptor.MessageSenderInterceptor.handleMessage(MessageSenderInterceptor.java:58)
>      [java]     at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:147)
>      [java]     at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:143)
>      [java]     at org.apache.cxf.jaxws.EndpointInvocationHandler.invokeSync(EndpointInvocationHandler.java:128)
>      [java]     at org.apache.cxf.jaxws.EndpointInvocationHandler.invoke(EndpointInvocationHandler.java:114)
>      [java]     at $Proxy34.pingMe(Unknown Source)
>      [java]     at demo.hw.client.Client.main(Client.java:78)
>      [java] Java Result: 1
> seems Fault doesn't work now in xml binding. I guess someone change something occasionally
cause this problem since I remember it should be fine days before

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message