cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Sierra Andrés <csie...@gmail.com>
Subject Re: ServiceConstructionException when adding JAX-RS application ruins existing applications
Date Thu, 15 Jun 2017 10:11:32 GMT
Hey Sergey,

I will.

In the meantime, I tried commenting out the server.destroy() invocation
in the version I was using and, indeed, it solved the problem. I must
admit I was skeptical because I use server.destroy() to remove
applications from the bus and it never had affected any other
application in the bus.

Do you think it is caused by the fact both applications share the same
prefix?

Thx.


El 15/6/17 a las 11:18, Sergey Beryozkin escribió:
> Yes please
>
> On 15/06/17 07:38, Carlos Sierra Andrés wrote:
>> Should I file a bug in jira then?
>>
>>
>> El 14/6/17 a las 17:35, Sergey Beryozkin escribió:
>>> Hi
>>>
>>> I see that the factory bean is destroying the server if a
>>> RuntimeException came in from server.start(). I guess it is what is
>>> causing the side-effects for the already running application which use
>>> the listener on that address...
>>>
>>> I think we may need to introduce ServerAlreadyRunningException and in
>>> this case do not call server.destroy()
>>>
>>> Dan, does it sound reasonable to you ?
>>>
>>> Thanks, Sergey
>>> On 14/06/17 16:30, Carlos Sierra Andrés wrote:
>>>> Hey there,
>>>>
>>>> I am trying to implement JAX-RS aries whiteboard on top of CXF and
>>>> I am
>>>> having problems with error handling. I have no problem adding new
>>>> applications to an existing bus but, if a new application conflicts
>>>> with
>>>> an existing one, an Exception:
>>>>
>>>> ---
>>>>
>>>> Caused by:
>>>> org.apache.cxf.service.factory.ServiceConstructionException:
>>>> There is an endpoint already running on /test-application.
>>>>       at
>>>> org.apache.cxf.jaxrs.JAXRSBindingFactory.addListener(JAXRSBindingFactory.java:86)
>>>>
>>>>
>>>>       at org.apache.cxf.endpoint.ServerImpl.start(ServerImpl.java:123)
>>>>       at
>>>> org.apache.cxf.jaxrs.JAXRSServerFactoryBean.create(JAXRSServerFactoryBean.java:206)
>>>>
>>>>
>>>>
>>>> ---
>>>>
>>>> is raised, which is expected. The problem is that the already existing
>>>> application ceases to work in the bus. Is this an expected behaviour?
>>>> Looks like a bug, doesn't it?
>>>>
>>>> Thx in advance!
>>>>
>>>>
>>>
>>>
>>


Mime
View raw message