cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Beryozkin <sberyoz...@gmail.com>
Subject Re: Upgrading Servlet API version to 3.1
Date Mon, 10 Oct 2016 14:12:13 GMT
Hi Andriy

This is what came in with the original contribution from Willem.
Looks like it has to be upgraded to the latest Netty which will work 
fine with Servlet 3.1

Cheers, Sergey
On 10/10/16 15:03, Andriy Redko wrote:
> Hey Sergey,
>
> Thanks a bunch, I am looking into Netty transport, it depends on Servlet 2.5,
> I am curious to know why ...
>
> Best Regards,
>     Andriy Redko
>
> SB> I've committed it to the master only
>
> SB> Cheers, Sergey
> SB> On 06/10/16 13:54, Sergey Beryozkin wrote:
>>> Hi
>
>>> I've started preparing CXF 3.2.0-SNAPSHOT only to move Servlet API 3.1
>>> [1]. In CXF 3.2.0 we'll most likely need it to support JAX-RS 2.1 NIO
>>> features and perhaps the JAX-WS frontend can be enhanced accordingly.
>>> It may also help us with improving the CXF web socket transport.
>
>>> We've been using geronimo servlet artifacts, but no geronimo servlet 3.1
>>> artifact exists and I've noticed Karaf 4 has been updated to use
>
>>> javax.servlet/javax.servlet-api/3.1.0
>
>>> Thus I'm also updating the master code to use this artifact - any
>>> concerns - let me know please.
>
>>> (The only exception is a netty server module - apparently this one still
>>> needs Servlet 2.5).
>
>>> Cheers, Sergey
>
>
>>> [1] https://issues.apache.org/jira/browse/CXF-7077
>
>
>


-- 
Sergey Beryozkin

Talend Community Coders
http://coders.talend.com/

Mime
View raw message