cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Redko <drr...@gmail.com>
Subject Re: Failing rs-sse system tests
Date Fri, 23 Sep 2016 16:03:55 GMT
Hi Sergey,

Right, you are coming to the same conclusions. This is what causes the
troubles, some state which I am trying to track down.
The issue is caused by flushing the response without sending any data along
with it (Atm does it and it causes NPE in Jetty).
I am going to try another fix tonight, if its not going to work, I will
comment out (ignore) test cases tonight as well.
Thanks.

Best Regards,
    Andriy Redko

On Fri, Sep 23, 2016 at 9:23 AM, Sergey Beryozkin <sberyozkin@gmail.com>
wrote:

> Hi Andriy
>
> The part which I do not understand is why running an individual Jetty test
> works but the same test fails if it is run second in the group of 2 tests.
> I can def help with investigating on Linux - but we'd need to disable them
> for now if you'd like me to look into it because I'll probably only have
> time some time next week
>
> Thanks, Sergey
> On 23/09/16 12:41, Andrey Redko wrote:
>
>> Hi Sergey,
>>
>> Exactly, this is what I was looking at for last couple of weeks, Atm has
>> a few hacks around Jetty, but seems like I run into uncovered flow.
>> The annoying part is that tests do not fail on Windows box, it makes
>> troubleshooting more complicated for me.  But I will definitely do
>> something about these test cases today.
>> Thanks.
>>
>> Best Rehatds.
>>     Andriy Redko
>>
>>
>> On Fri, Sep 23, 2016 at 6:30 AM, Sergey Beryozkin <sberyozkin@gmail.com
>> <mailto:sberyozkin@gmail.com>> wrote:
>>
>>     Hi Andriy
>>
>>     Interesting. I wonder if Jetty can be tuned somehow so that as far
>>     as ATM is concerned the same code path is used there irrespectively
>>     of whether it is Jetty or Tomcat - given that with Tomcat the tests
>> pass
>>
>>     Thanks, Sergey
>>
>>     On 23/09/16 11:22, Andriy Redko wrote:
>>
>>         Hey Sergey,
>>
>>         Yeah, I have gotten all them green on my machine (always failing
>>         before) and
>>         thought they are fixed now, will look more today. It is
>>         definitely Jetty
>>         specific, I know why Jetty fails but I have not found a way to
>>         workaround
>>         that (it is deeply inside Atm). I will spend more time today and
>>         in worst
>>         case just please comment them out if it something blocking you
>> guys.
>>
>>         Thanks!
>>
>>         Best Regards,
>>             Andriy Redko
>>
>>         SB> Looks like it is a test (or SSE impl) state issue,
>>         SB> Andriy, FYI, if I run complete JettyEmbeddedTest then I see:
>>
>>
>>         SB> testBooksStreamIsReturnedFromLastEventId - OK
>>         SB> testBooksAreReturned - Fail
>>
>>         SB> If I only run
>>
>>         SB> JettyEmbeddedTest.testBooksAreReturned
>>
>>         SB> then it is green.
>>
>>         SB> Same tests run with Tomcat though (I wonder by the way if
>>         CXF should
>>         SB> have an http-tomcat transport too).
>>         SB> So may be it is Jetty specific ?
>>
>>         SB> Cheers, Sergey
>>
>>         SB> On 23/09/16 10:14, Colm O hEigeartaigh wrote:
>>
>>                 No apologies necessary Andriy! We all inadvertently
>>                 break tests.
>>
>>
>>                 Both tests are still failing for me however:
>>
>>
>>                 Failed tests:
>>
>>
>>                 JettyEmbeddedTest>AbstractSseT
>> est.testBooksAreReturned:62->Assert.assertEquals:631->Assert
>> .assertEquals:645->Assert.failNotEquals:834->Assert.fail:88
>>                 expected:<200> but was:<500>
>>
>>
>>                 JettyWarTest>AbstractSseTest.t
>> estBooksAreReturned:62->Assert.assertEquals:631->Assert.
>> assertEquals:645->Assert.failNotEquals:834->Assert.fail:88
>>                 expected:<200> but was:<500>
>>
>>
>>                 My Java version is "1.8.0_101" on linux if that helps.
>>
>>
>>                 Colm.
>>
>>
>>                 On Fri, Sep 23, 2016 at 2:33 AM, Andriy Redko
>>                 <drreta@gmail.com <mailto:drreta@gmail.com>> wrote:
>>
>>
>>                     Hey Colm,
>>
>>
>>                     My bad, worked on a solution but it took awhile. The
>>                     fix was finally
>>                     committed a few
>>                     minutes ago, should be OK from now on. Please accept
>>                     my apologies.
>>
>>
>>                     Best Regards,
>>                         Andriy Redko
>>
>>
>>                     COh> The following tests are failing for me on the
>>                     master branch:
>>
>>
>>                     COh> Failed tests:
>>
>>
>>                     JettyEmbeddedTest>>AbstractSse
>> Test.testBooksAreReturned:73->
>>                     Assert.assertEquals:631->Assert.assertEquals:645->
>>                     Assert.failNotEquals:834->Assert.fail:88
>>                     COh> expected:<200> but was:<500>
>>
>>
>>                     JettyWarTest>>AbstractSseTest.
>> testBooksAreReturned:73->
>>                     Assert.assertEquals:631->Assert.assertEquals:645->
>>                     Assert.failNotEquals:834->Assert.fail:88
>>                     COh> expected:<200> but was:<500>
>>                     COh> Tests in error:
>>                     COh>
>>                      TomcatEmbeddedTest>AbstractSs
>> eTest.testBooksStreamIsBroadcasted:101
>>                     ยป
>>                     COh> ResponseProcessing
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>     --
>>     Sergey Beryozkin
>>
>>     Talend Community Coders
>>     http://coders.talend.com/
>>
>>
>>
>
> --
> Sergey Beryozkin
>
> Talend Community Coders
> http://coders.talend.com/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message