cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andriy Redko <drr...@gmail.com>
Subject Re: Failing rs-sse system tests
Date Fri, 23 Sep 2016 10:22:07 GMT
Hey Sergey,

Yeah, I have gotten all them green on my machine (always failing before) and
thought they are fixed now, will look more today. It is definitely Jetty
specific, I know why Jetty fails but I have not found a way to workaround
that (it is deeply inside Atm). I will spend more time today and in worst
case just please comment them out if it something blocking you guys.

Thanks!

Best Regards,
    Andriy Redko

SB> Looks like it is a test (or SSE impl) state issue,
SB> Andriy, FYI, if I run complete JettyEmbeddedTest then I see:


SB> testBooksStreamIsReturnedFromLastEventId - OK
SB> testBooksAreReturned - Fail

SB> If I only run

SB> JettyEmbeddedTest.testBooksAreReturned

SB> then it is green.

SB> Same tests run with Tomcat though (I wonder by the way if CXF should 
SB> have an http-tomcat transport too).
SB> So may be it is Jetty specific ?

SB> Cheers, Sergey

SB> On 23/09/16 10:14, Colm O hEigeartaigh wrote:
>> No apologies necessary Andriy! We all inadvertently break tests.

>> Both tests are still failing for me however:

>> Failed tests:

>> JettyEmbeddedTest>AbstractSseTest.testBooksAreReturned:62->Assert.assertEquals:631->Assert.assertEquals:645->Assert.failNotEquals:834->Assert.fail:88
>> expected:<200> but was:<500>

>> JettyWarTest>AbstractSseTest.testBooksAreReturned:62->Assert.assertEquals:631->Assert.assertEquals:645->Assert.failNotEquals:834->Assert.fail:88
>> expected:<200> but was:<500>

>> My Java version is "1.8.0_101" on linux if that helps.

>> Colm.

>> On Fri, Sep 23, 2016 at 2:33 AM, Andriy Redko <drreta@gmail.com> wrote:

>>> Hey Colm,

>>> My bad, worked on a solution but it took awhile. The fix was finally
>>> committed a few
>>> minutes ago, should be OK from now on. Please accept my apologies.

>>> Best Regards,
>>>     Andriy Redko

>>> COh> The following tests are failing for me on the master branch:

>>> COh> Failed tests:

>>> JettyEmbeddedTest>>AbstractSseTest.testBooksAreReturned:73->
>>> Assert.assertEquals:631->Assert.assertEquals:645->
>>> Assert.failNotEquals:834->Assert.fail:88
>>> COh> expected:<200> but was:<500>

>>> JettyWarTest>>AbstractSseTest.testBooksAreReturned:73->
>>> Assert.assertEquals:631->Assert.assertEquals:645->
>>> Assert.failNotEquals:834->Assert.fail:88
>>> COh> expected:<200> but was:<500>
>>> COh> Tests in error:
>>> COh>   TomcatEmbeddedTest>AbstractSseTest.testBooksStreamIsBroadcasted:101
>>> ยป
>>> COh> ResponseProcessing











Mime
View raw message