cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm O hEigeartaigh <cohei...@apache.org>
Subject Re: [DISCUSS] UI for Fediz IDP - update -
Date Wed, 24 Aug 2016 14:08:42 GMT
Hi Aymen,

I installed npm locally but still get the error:

> fediz-idp-ui@0.0.0 postinstall
/tmp/cxf-fediz/services/idp/src/main/fedizui
> typings install

/usr/bin/env: ‘node’: No such file or directory

What do I have to do to set it up? Is there any possibility to a maven
plugin like (https://github.com/eirslett/frontend-maven-plugin) to get this
working?

Colm.

On Sun, Aug 21, 2016 at 9:56 PM, Aymen Furter <aymen.furter@prodyna.com>
wrote:

> Hi there!
>
> A little update regarding the Fediz IDP UI I am currently building:
> - Integrated into Maven Build Process
>   See my fork: https://github.com/aymenfurter/cxf-fediz
>   (However, this creates a dependency. The Build Server needs to have npm
> installed. Is this an issue?)
> - An error message is displayed when a server error occurs.
> - Lists do now get updated consistently.
> - Login now works correctly (However, it's still Basic Auth based)
> - I currently face an issue when accessing objects using the REST Api that
> have "/" in them.
>   (e.g. http://idp.aymenfurter.ch:8040/services/rs/claims/http:/
> /schemas.xmlsoap.org/ws/2005/05/identity/claims/givenname)
>   Maybe an issue regarding my Tomcat Setup? If someone has input regarding
> this I would be very thankful!
> - Testinstance is running here: http://idp.aymenfurter.ch:
> 8040/admin/index.html (default credentials)
>
>
> best regards
> Aymen
>
>


-- 
Colm O hEigeartaigh

Talend Community Coder
http://coders.talend.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message