cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix.1973" <felix.merca...@omnipaygroup.com>
Subject Re: Why Apache CXF not being used in WebLogic 12c ?
Date Thu, 02 Oct 2014 15:44:57 GMT
No, no, I did not touch the Weblogic installation. As I develop with Intellij
(btw I am not using MAVEN), when I enabled CXF support for my project, then
all CXF runtime was included in my project which I guess it is good because
all these jars were included in my EAR so also deployed when I went to
Weblogic 12c.

But this CXF runtime include jars from the lib folder of CXF 2.7.12 (this is
more than 70 jars, from activemq-broker-5.8.0.jar to xsdlib-2010.1.jar
alphabetically). But none of your 11 jars were included because these 11
jars I see them in the "modules" folder of CXF 2.7.12, not the lib folder.

So now my EAR include these more than 70 jars (except the two discovery ones
that Daniel told me to remove) plus your 11 jars. 

Does it make any sense to you now ? Again, I am not using maven, so Intellij
added automatically the first 70 plus now I added manually your 11, but
still not working. And I also added in my Weblogic startup

JAVA_OPTIONS="-Dorg.apache.cxf.binding.soap.messageFactoryClassName=com.sun.xml.internal.messaging.saaj.soap.ver1_1.SOAPMessageFactory1_1Impl
${JAVA_OPTIONS}" 

but still using the wrong classes  :-(



--
View this message in context: http://cxf.547215.n5.nabble.com/Why-Apache-CXF-not-being-used-in-WebLogic-12c-tp5749219p5749394.html
Sent from the cxf-dev mailing list archive at Nabble.com.

Mime
View raw message