cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Why Apache CXF not being used in WebLogic 12c ?
Date Fri, 26 Sep 2014 12:09:59 GMT
Do you have a jaxws-api jar in your war/ear?  If so, try removing it (and pretty much all the
other api jars) and use the version provided by the jre/weblogic.   That may help.

That said, not sure why it’s still trying to create the weblogic.wsee.jaxws.spi.WLSProvider
thing.  

Dan



On Sep 26, 2014, at 6:14 AM, Felix.1973 <felix.mercader@omnipaygroup.com> wrote:

> Hi 
> 
> Daniel, I tried what you said, this is declaring an endpoint in my
> cxf-servlet.xml. I added the following lines:
> 
>    <import resource="classpath:META-INF/cxf/cxf.xml"/>
>    <import resource="classpath:META-INF/cxf/cxf-servlet.xml"/>
>    <jaxws:endpoint id="helloWorld" implementor="example.HelloWorldImpl"
> address="/HelloWorld"/>
> 
> And now, when I deploy in WebLogic 12c I am getting this error:
> 
> java.lang.ClassCastException: weblogic.wsee.jaxws.spi.WLSProvider cannot be
> cast to javax.xml.ws.spi.Provider
> 
> Any idea ? In weblogic logs I see this error and then references to cxf, so
> it looks promising, but I don't see how to fix it. 
> 
> Thanks Daniel
> 
> 
> 
> 
> --
> View this message in context: http://cxf.547215.n5.nabble.com/Why-Apache-CXF-not-being-used-in-WebLogic-12c-tp5749219p5749272.html
> Sent from the cxf-dev mailing list archive at Nabble.com.

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message