cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix.1973" <felix.merca...@omnipaygroup.com>
Subject Why Apache CXF not being used in WebLogic 12c ?
Date Thu, 25 Sep 2014 11:57:14 GMT
Hi there 

I need help as I tried many things, I checked the Internet for help for many
days but still having the same problem. Please any help would be very
appreciated.

I am developing using IDEA Intellij 11.0.2. Inside Intellij works perfectly
as CXF is used. I deploy with no error in WebLogic 12c but at runtime, CXF
is not used and this is what I need to fix.

I use JDK 1.7.0 plus Apache CXF 2.7.12. 

It seems for sure a configuration problem because if I debug my WebService
in Intellij with a Thread.dumpStack(), I get the following (perfect! a lot
of org.apache.cxf references appear):

java.lang.Exception: Stack trace
	at java.lang.Thread.dumpStack(Thread.java:1365)
	at example.HelloWorldImpl.sayHelloWorldFrom(HelloWorldImpl.java:18)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	*at
org.apache.cxf.service.invoker.AbstractInvoker.performInvocation(AbstractInvoker.java:188)*
at
org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:104)
	at
org.apache.cxf.jaxws.AbstractJAXWSMethodInvoker.invoke(AbstractJAXWSMethodInvoker.java:237)
	at
org.apache.cxf.jaxws.JAXWSMethodInvoker.invoke(JAXWSMethodInvoker.java:69)
	at
org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:75)
	at
org.apache.cxf.interceptor.ServiceInvokerInterceptor$1.run(ServiceInvokerInterceptor.java:58)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at
org.apache.cxf.workqueue.SynchronousExecutor.execute(SynchronousExecutor.java:37)
	at
org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage(ServiceInvokerInterceptor.java:107)
	at
org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:272)
	at
org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:121)
	at
org.apache.cxf.transport.http_jetty.JettyHTTPDestination.serviceRequest(JettyHTTPDestination.java:355)
	at
org.apache.cxf.transport.http_jetty.JettyHTTPDestination.doService(JettyHTTPDestination.java:319)
	at
org.apache.cxf.transport.http_jetty.JettyHTTPHandler.handle(JettyHTTPHandler.java:65)
	at
org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1088)
	at
org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1024)
	at
org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
	at
org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
	at
org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
	at org.eclipse.jetty.server.Server.handle(Server.java:370)
	at
org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
	at
org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:982)
	at
org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1043)
	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:865)
	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)
	at
org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
	at
org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)
	at
org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)
	at
org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
	at
org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
	at java.lang.Thread.run(Thread.java:745)


But when I debug the WebService in WebLogic with Thread.dumpStack(), I get
the following (no references to org.apache.cxf but to weblogic.wsee.jaxws so
cxf is not being used!):


java.lang.Throwable
        at java.lang.Thread.dumpStack(Thread.java:464)
        at example.HelloWorldImpl.sayHelloWorldFrom(HelloWorldImpl.java:18)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
        at java.lang.reflect.Method.invoke(Method.java:618)
        *at
weblogic.wsee.jaxws.WLSInstanceResolver$WLSInvoker.invoke(WLSInstanceResolver.java:117)* 
     
at
weblogic.wsee.jaxws.WLSInstanceResolver$WLSInvoker.invoke(WLSInstanceResolver.java:91)
        at com.sun.xml.ws.server.InvokerTube$2.invoke(InvokerTube.java:149)
        at
com.sun.xml.ws.server.sei.SEIInvokerTube.processRequest(SEIInvokerTube.java:88)
        at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:1136)
        at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:1050)
        at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:1019)
        at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:877)
        at
com.sun.xml.ws.server.WSEndpointImpl$2.process(WSEndpointImpl.java:419)
        at
com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:868)
        at
com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:422)
        at
com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:169)
        at
weblogic.wsee.jaxws.WLSServletAdapter.handle(WLSServletAdapter.java:199)
        at
weblogic.wsee.jaxws.HttpServletAdapter$AuthorizedInvoke.run(HttpServletAdapter.java:640)
        at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
        at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:146)
        at
weblogic.wsee.util.ServerSecurityHelper.authenticatedInvoke(ServerSecurityHelper.java:108)
        at
weblogic.wsee.jaxws.HttpServletAdapter$3.run(HttpServletAdapter.java:284)
        at
weblogic.wsee.jaxws.HttpServletAdapter.post(HttpServletAdapter.java:293)
        at weblogic.wsee.jaxws.JAXWSServlet.doRequest(JAXWSServlet.java:128)
        at
weblogic.servlet.http.AbstractAsyncServlet.service(AbstractAsyncServlet.java:99)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:844)
        at
weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:280)
        at
weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:254)
        at
weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:136)
        at
weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:346)
        at
weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:243)
        at
weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3432)
        at
weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3402)
        at
weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
        at
weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
        at
weblogic.servlet.provider.WlsSubjectHandle.run(WlsSubjectHandle.java:57)
        at
weblogic.servlet.internal.WebAppServletContext.doSecuredExecute(WebAppServletContext.java:2285)
        at
weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2201)
        at
weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2179)
        at
weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1572)
        at
weblogic.servlet.provider.ContainerSupportProviderImpl$WlsRequestExecutor.run(ContainerSupportProviderImpl.java:255)
        at weblogic.work.ExecuteThread.execute(ExecuteThread.java:311)
        at weblogic.work.ExecuteThread.run(ExecuteThread.java:263)


Any idea why this is happening ? I tried many things. For instance this link
(which it says validated for WebLogic 9.2 but I am using WebLogic 12c):

http://cxf.apache.org/docs/application-server-specific-configuration-guide.html#ApplicationServerSpecificConfigurationGuide-WebLogic

So I have an application.xml, a web-logic-application.xml which includes
javax.jws.* as prefer-application-packages. I don't know what else to try.
CXF is never used.

Some code (the WebService is just a HelloWorld example, nothing else nothing
more):


1) application.xml


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE application PUBLIC        &quot;-//Sun Microsystems, Inc.//DTD
J2EE Application 1.3//EN&quot;       
&quot;http://java.sun.com/dtd/application_1_3.dtd&quot;>
<application>
    <display-name>testCXF</display-name>
    <module>
        <web>
            <web-uri>testCXF_war_exploded.war</web-uri>
            <context-root>/</context-root>
        </web>
    </module>
</application>


2) weblogic-application.xml


<?xml version="1.0" encoding="UTF-8"?>
<weblogic-application xmlns="http://www.bea.com/ns/weblogic/90">
    <application-param>
        <param-name>webapp.encoding.default</param-name>
        <param-value>UTF-8</param-value>
    </application-param>
    <prefer-application-packages>
        <package-name>javax.jws.*</package-name>
    </prefer-application-packages>
</weblogic-application>


3) cxf-servlet.xml


<?xml version="1.0" encoding="UTF-8"?>

<beans xmlns="http://www.springframework.org/schema/beans"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:jaxws="http://cxf.apache.org/jaxws"
      xmlns:soap="http://cxf.apache.org/bindings/soap"
      xsi:schemaLocation="
http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
http://cxf.apache.org/bindings/soap
http://cxf.apache.org/schemas/configuration/soap.xsd
http://cxf.apache.org/jaxws http://cxf.apache.org/schemas/jaxws.xsd">
</beans>


4) web.xml


<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://java.sun.com/xml/ns/javaee"
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
		  http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
           version="2.5">
    <description>cxf</description>

    <display-name>cxf</display-name>
    <servlet>
        <description>Apache CXF Endpoint</description>
        <display-name>cxf</display-name>
        <servlet-name>cxf</servlet-name>
       
<servlet-class>org.apache.cxf.transport.servlet.CXFServlet</servlet-class>
        <load-on-startup>1</load-on-startup>
    </servlet>
    <servlet-mapping>
        <servlet-name>cxf</servlet-name>
        <url-pattern>/services/*</url-pattern>
    </servlet-mapping>
    <session-config>
        <session-timeout>60</session-timeout>
    </session-config>
</web-app>


What I am doing wrong ? how should I deploy in WebLogic 12c to have CXF used
?

thanks 
Felix Mercader. 


<http://cxf.547215.n5.nabble.com/file/n5749219/cxf.jpg> 



--
View this message in context: http://cxf.547215.n5.nabble.com/Why-Apache-CXF-not-being-used-in-WebLogic-12c-tp5749219.html
Sent from the cxf-dev mailing list archive at Nabble.com.

Mime
View raw message