cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@gmail.com>
Subject ehcache version used in cxf build
Date Wed, 03 Jul 2013 20:58:04 GMT
cxf's trunk and branches (2.7.x, 2.6.x, etc) all use ehcache 2.5.1 and
create the karaf feature with the corresponding smx's bundle version. But
the version range specified in the package imports is set as [2.5.0,3.0.0),
so we could use a newer version in runtime.

As ehcache 2.5.1 is rather old (from 2012-01) and there are newer versions
such as 2.6.6 (2013-05) and 2.7.2 (2013-07) which is already an
osgi-bundle,  I was wondering if we can use a newer version for trunk's
build. There are some disappeared classes and other changes, but the usage
in cxf seem to be compatible with these versions. I tried both 2.6.6 and
2.7.2, and the build itself seems to run without problems.

How do you think about upgrading ehcache to ehcache 2.7.2 for trunk so that
we can test cxf not just against old ehcache 2.5.1?

As comparison, camel trunk uses ehcache 2.7.0, while 2.11.x uses 2.5.2.

regards, aki

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message