cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "A. Rothman" <amich...@amichais.net>
Subject Re: DOSGi 1.5.0 systests failing inconsistently
Date Thu, 04 Jul 2013 09:30:42 GMT
Christian,

This doesn't look like it's only about reusing ports (though I added 
socket.setReuseAddress in getFreePort() for what it's worth if you feel 
like tinkering).

I opened https://issues.apache.org/jira/browse/DOSGI-199 and 
https://issues.apache.org/jira/browse/DOSGI-200 with two exceptions I'm 
seeing during tests. The first seems non-critical and solvable by 
pax-web/jetty upgrades (we're on pretty old versions). The second looks 
more serious, and may be the cause of at least some of the failures.

Currently I'm getting < 50% success rate on system tests when running 
them in a loop.

Amichai

On 07/03/2013 08:45 AM, Christian Schneider wrote:
> Hi Amichai,
>
> I see the failurs on jenkins but was not able to reproduce them locally. So
> I assumed the port simply is used by another test running in parallel at
> this point. Of course it may also be a problem in our code. I tried to find
> a way to find a free port dynamically but my aproach did not seem to work.
> Whenever I discovered a free port it was then blocked when I used it in the
> test.
>
> Christian
>
>
> 2013/7/3 A. Rothman <amichai2@amichais.net>
>
>> Hi,
>>
>> I've noticed in the past couple of days that the multi-bundle system tests
>> module is inconsistently failing with the exception "Timeout waiting for
>> web page http://localhost:9091/greeter/**greeter/greeting/Chris<http://localhost:9091/greeter/greeter/greeting/Chris>".
>> If I run a full mvn clean install several times in a row, it fails in some
>> and succeeds in others. I thought it may be related to
>> https://issues.apache.org/**jira/browse/DOSGI-198<https://issues.apache.org/jira/browse/DOSGI-198>which
I just fixed, but still getting some failures both with trunk and
>> with the 1.5.0 tag revision.
>>
>> Is anyone else seeing this?
>>
>> And a related question, does anyone know how to restart a bundle within a
>> pax exam test?
>>
>> Amichai
>>
>>
>>



Mime
View raw message