cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Freeman Fang <freeman.f...@gmail.com>
Subject Re: Invalid SOAP Fault
Date Thu, 20 Jun 2013 00:58:03 GMT
Hi,

This should be discussed in users mailing list.

You are using ws-security, right?

You may wanna take a look at ws_security examples shipped with CXF kit, especially the sign_enc,
to get some concrete idea how it works.
-------------
Freeman(Yue) Fang

Red Hat, Inc. 
FuseSource is now part of Red Hat
Web: http://fusesource.com | http://www.redhat.com/
Twitter: freemanfang
Blog: http://freemanfang.blogspot.com
http://blog.sina.com.cn/u/1473905042
weibo: @Freeman小屋



On 2013-6-19, at 下午10:26, selvanayagam wrote:

> Hi,
> Thanks for your fast reply.
> 
> Now when I connect to server server throws the blow message. How to solve the below issue?
> 
> [WARN] Interceptor for {http://www.merge.com/services}DICOMWebServiceMTOMDisabled has
thrown exception, unwinding now
> org.apache.cxf.binding.soap.SoapFault: General security error (WSSecurityEngine: No crypto
property file supplied for decryption)
> ....
> ....
> Caused by: org.apache.ws.security.WSSecurityException: General security error (WSSecurityEngine:
No crypto property file supplied for decryption)
>    at org.apache.ws.security.processor.EncryptedKeyProcessor.handleToken(EncryptedKeyProcessor.java:67)
> 
> On 19-06-2013 06:35, Freeman Fang wrote:
>> Hi,
>> 
>> This error means your .net client expect a SOAP 1.2 fault but the CXF server return
a SOAP 1.1 fault.
>> 
>> This is caused by you have a SOAP 1.1 server but a SOAP 1.2 client, you need fix
this mismatch.
>> -------------
>> Freeman(Yue) Fang
>> 
>> Red Hat, Inc.
>> FuseSource is now part of Red Hat
>> Web: http://fusesource.com | http://www.redhat.com/
>> Twitter: freemanfang
>> Blog: http://freemanfang.blogspot.com
>> http://blog.sina.com.cn/u/1473905042
>> weibo: @Freeman小屋
>> 
>> 
>> 
>> On 2013-6-18, at 下午9:25, selvanayagam wrote:
>> 
>>> I have java web service using CXF 2.6.2 with JAX_WS. When trying to consume this
web service in .Net C# client we get the below error.
>>> 
>>> Server returned an invalid SOAP Fault. Please see InnerException for more details.
---> System.Xml.XmlException: Start element 'Code' from namespace 'http://www.w3.org/2003/05/soap-envelope'
expected. Found element 'faultcode' from namespace.
>>> 
>>> As per the investigation, the .Net client sends the message using SOAP 1.1, whereas
the server application uses SOAP 1.2.
>>> 
>>> Can anyone suggest me what would be problem?
>> 
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message