cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schneider <ch...@die-schneider.net>
Subject Re: [cxf] Problem migrating from 1.3 to 1.4 DOSGi Single Distr
Date Mon, 20 May 2013 10:42:59 GMT
Hi Dhiego,

the single bundle distro is not tested as well as the multi bundle 
distro. Could you check if the error also happens for the multibundle 
distro?
Btw. for version 1.5 we completely remove the single bundle distro as it 
was too difficult to maintain in the long run. So you will have to move 
to the multi bundle distro
when you upgrade to the next version anyway.

Christian

Am 20.05.2013 05:36, schrieb Dhiego Abrantes de Oliveira Martins:
> Hi,
>
> Now I'm using version 1.4.0 of DOSGi Single Distro and I can perceive some
> points:
>
> 1- I cant setup zookeeper by
> 'load/org.apache.cxf.dosgi.discovery.zookeeper.cfg' file. Simply the
> changes dont make any effect.
> 2- When I try to start a WebService, I got the message bellow:
>
> -> Mai 20, 2013 12:25:33 AM
> org.apache.cxf.service.factory.ReflectionServiceFactoryBean
> buildServiceFromClass
> INFO: Creating Service
> {http://hiService.ws.dhiego.br/}HiServiceServicefrom class
> br.dhiego.ws.hiService.HiService
> Mai 20, 2013 12:25:33 AM org.apache.cxf.endpoint.ServerImpl initDestination
> INFO: Setting the server's publish address to be
> http://localhost:9090/hiService
>
> The log register an action as 'Setting the server's publish address to
> be...', but not happens after that. However, the service is accessible.
>
> When I'm using 1.3 version, a lot of log is written in console and I got
> some information about service publication, for example:
>
> *** EndpointDescription: ****
> component  => br.dhiego.ws.hiService.impl.HiServiceImpl
> endpoint.framework.uuid  => 2c8dcd08-b4fc-48a4-a129-16f1a043a9d0
> endpoint.id  => http://localhost:9090/hiService
> endpoint.package.version.br.dhiego.ws.hiService  => 0.0.0
> endpoint.service.id  => 45
> factory.name  => br.dhiego.ws.hiService.impl.HiServiceImpl
> instance.name  => br.dhiego.ws.hiService.impl.HiServiceImpl-0
> objectClass  => [Ljava.lang.String;@2183ef8c
> org.apache.cxf.ws.address  => http://localhost:9090/hiService
> service.imported  => true
> service.imported.configs  => [Ljava.lang.String;@5ce3e184
> service.intents  => [Ljava.lang.String;@74ead0c0
> ]
>
> There are some way to fix it when I'm using new version (1.4) of DOSGi
> Single bundle?
>
> Thanks in advance!
> __
> *Dhiego*
>


-- 
  
Christian Schneider
http://www.liquid-reality.de

Open Source Architect
Talend Application Integration Division http://www.talend.com


Mime
View raw message