cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@googlemail.com>
Subject Re: JMX enabling in CXF 2.2.6
Date Mon, 23 Apr 2012 20:08:22 GMT
Which properties did you configure and where is your application
running? Depending on the container, you need to set some properties
differently.

You might be starting another default server although the server is
available in the container. In that way, you are not seeing the CXF
beans.

regards, aki

2012/4/23 nsmith9334 <nsmith9334@gmail.com>:
> Thank you for your quick response.
> I have configured the JMX according to the link given below.
>
> Also, based on your input, I have changed my configuration such that the
> bus property gets set first. I still dont see the CXF mbean.'
>
> Any ideas what could be the problem?
>
> Thanks,
> Nick
>
>
> On Mon, Apr 23, 2012 at 1:26 AM, Aki Yoshida-2 [via CXF] <
> ml-node+s547215n5658681h24@n5.nabble.com> wrote:
>
>> Hi,
>> there was a bug CXF-4170 that got into 2.5.2 when the code was changed
>> to solve another issue and also to add a simpler configuration option.
>>
>> This problem caused the bean properties to incorrectly set when the
>> bus property is not set as the first entry within its bean
>> configuration (i.e., . when the InstrumentationManagerImpl bean is
>> directly configured).
>>
>> To avoid this problem in 2.5.2, you need to move the bus property at
>> the top. Alternatively,  you can also configure the instrumentation
>> manager bean using the bus properties, as shown in the online page:
>>
>> http://cxf.apache.org/docs/jmx-management.html
>>
>> regards, aki
>>
>> 2012/4/23 nsmith9334 <[hidden email]<http://user/SendEmail.jtp?type=node&node=5658681&i=0>>:
>>
>>
>> > Hi ,
>> >
>> > I am trying to enable JMX for CXF 2.5.2 and I seem to have encountered
>> the
>> > same problem as above.
>> > I was able to successfully connect to the server using JConsole but I do
>> not
>> > see any CXF MBeans.
>> >
>> > Based on one of the solutions discussed above, I tried to create a new
>> > connection to the JConsole using the JMX URL and username/passsword
>> > (cxf/cxf) and I was unable to get the JConsole CXF Mbeans.
>> >
>> > Any pointers as to how I can solve this issue?
>> >
>> >
>> > --
>> > View this message in context:
>> http://cxf.547215.n5.nabble.com/JMX-enabling-in-CXF-2-2-6-tp577074p5658219.html
>> > Sent from the cxf-dev mailing list archive at Nabble.com.
>>
>>
>> ------------------------------
>>  If you reply to this email, your message will be added to the discussion
>> below:
>>
>> http://cxf.547215.n5.nabble.com/JMX-enabling-in-CXF-2-2-6-tp577074p5658681.html
>>  To unsubscribe from JMX enabling in CXF 2.2.6, click here<http://cxf.547215.n5.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=577074&code=bnNtaXRoOTMzNEBnbWFpbC5jb218NTc3MDc0fC01ODc3NTg1NjU=>
>> .
>> NAML<http://cxf.547215.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>>
>
>
> --
> View this message in context: http://cxf.547215.n5.nabble.com/JMX-enabling-in-CXF-2-2-6-tp577074p5659914.html
> Sent from the cxf-dev mailing list archive at Nabble.com.

Mime
View raw message